Project

General

Profile

Bug #11802

Underexpose warning does not always work

Added by Paolo Astengo over 1 year ago. Updated over 1 year ago.

Status:
Fixed
Priority:
Low
Category:
Darkroom
Target version:
Start date:
11/01/2017
Due date:
% Done:

100%

Affected Version:
git master branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I'm attaching some screenshots. After applying the base curve for Pentax K-5, if the threshold for underexpose warning is set to 0%, the false color does not colorize the RGB 0,0,0 pixels.

If you set the threshold to more than 0%, the warning starts to work. When the threshold is placed to 0%, it colorize the edges only

Schermata da 2017-11-01 20-53-33.png (649 KB) Paolo Astengo, 11/01/2017 10:02 PM

Schermata da 2017-11-01 20-53-43.png (663 KB) Paolo Astengo, 11/01/2017 10:02 PM

Schermata da 2017-11-01 20-53-48.png (673 KB) Paolo Astengo, 11/01/2017 10:03 PM

Schermata da 2017-11-01 20-53-58.png (645 KB) Paolo Astengo, 11/01/2017 10:03 PM

Schermata da 2017-11-01 20-56-18.png - Without base curve (531 KB) Paolo Astengo, 11/01/2017 10:03 PM

Schermata da 2017-11-01 20-53-52.png (673 KB) Paolo Astengo, 11/01/2017 10:03 PM

Schermata da 2017-11-01 20-57-03.png (241 KB) Paolo Astengo, 11/01/2017 10:03 PM

Schermata da 2018-02-25 16-48-38.resized.png (1.23 MB) Paolo Astengo, 02/25/2018 05:50 PM

Associated revisions

Revision 9cff7a3b
Added by Ulrich Pegelow over 1 year ago

opencl: fix bug #11802

root cause are rounding errors. also: fix a bug in the non-SSE2 CPU codepath.

History

#1 Updated by Paolo Astengo over 1 year ago

This issue appears only if opencl is enabled. An opencl overxepose kernel module bug?

#2 Updated by Ulrich Pegelow over 1 year ago

  • % Done changed from 0 to 10
  • Status changed from New to Confirmed
  • Assignee set to Ulrich Pegelow

I can confirm that there is a difference between CPU and OpenCL in the over/underexposed warning.

#3 Updated by Ulrich Pegelow over 1 year ago

  • Target version set to 2.4.0
  • % Done changed from 10 to 100
  • Status changed from Confirmed to Fixed

#4 Updated by Paolo Astengo over 1 year ago

It seems there is a regression on that issue.

#5 Updated by Paolo Astengo over 1 year ago

with and without opencl activated

#6 Updated by Tobias Ellinghaus over 1 year ago

And what is wrong about that image? What would you expect to see differently?

#7 Updated by Paolo Astengo over 1 year ago

it seemed to me that only the edges were highlighted and black parts were not. But I'll check better

Also available in: Atom PDF