Project

General

Profile

Bug #11801

JPEG Export of image contains artefacts

Added by Walter Beichl about 2 years ago. Updated over 1 year ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
11/01/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

While exporting some images to jpeg some of them (3 out of 20) contain artefacts (see attached image)

_1450309-dt.jpg (4.81 MB) _1450309-dt.jpg Walter Beichl, 11/01/2017 12:20 PM
DSCN9129_01.jpg (744 KB) DSCN9129_01.jpg Artefacts with false colors in darktable exported JPEG anu l, 07/23/2018 09:45 AM

History

#1 Updated by Ulrich Pegelow about 2 years ago

a) If you are running with OpenCL enabled please try without.

b) What happens if you export to some other output format (PNG)?

#2 Updated by Ulrich Pegelow about 2 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

#3 Updated by Walter Beichl about 2 years ago

When trying to reproduce the artefacts once more the export worked flawlessly independent of the OpenCL setting and export format (tried png, jpeg and tiff). I can't reproduce the artefacts any more.

#4 Updated by Tobias Ellinghaus about 2 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

Feel free to report back once it fails again.

#5 Updated by anu l over 1 year ago

Tobias Ellinghaus wrote:

Feel free to report back once it fails again.

I am getting the same issue on my laptop.
In fact the pixels at the same location of the file posted above seem to get affected.

Have a look at the attached file.

Laptop configuration is:
Darktable 2.4.4 win 64 bit
Nvidia 740m and gen4 i5 4200u, windows 8.1 64 bit.

#6 Updated by anu l over 1 year ago

anu l wrote:

Tobias Ellinghaus wrote:

Feel free to report back once it fails again.

I am getting the same issue on my laptop.
In fact the pixels at the same location of the file posted above seem to get affected.

Have a look at the attached file.

Laptop configuration is:
Darktable 2.4.4 win 64 bit
Nvidia 740m and gen4 i5 4200u, windows 8.1 64 bit.

update - The issue does not occur with every JPEG export. It happens with around one in 10 files.

#7 Updated by Ulrich Pegelow over 1 year ago

Could you please check the proposals from reply #1.

Also available in: Atom PDF

Go to top