Project

General

Profile

Bug #11764

Pentax K5 color matrix not found

Added by Paolo Astengo over 2 years ago. Updated over 2 years ago.

Status:
Incomplete
Priority:
Low
Assignee:
-
Category:
Tethering
Target version:
-
Start date:
10/08/2017
Due date:
% Done:

20%

Estimated time:
Affected Version:
git master branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Trying the tethering with Pentax K5 I receive this error: "PENTAX K-5' color matrix not found!" together with the following messages:

[rawspeed] (20171008_0005.pef) void rawspeed::ByteStream::check(rawspeed::Buffer::size_type) const, line 72: Out of bounds access in ByteStream
[temperature] failed to read camera white balance information from `20171008_0005.pef'!
[temperature] failed to read camera white balance information from `20171008_0005.pef'!
allocation failed???
[colorin] ` PENTAX K-5' color matrix not found!
[colorin] ` PENTAX K-5' color matrix not found!
[colorin] ` PENTAX K-5' color matrix not found!
[temperature] failed to read camera white balance information from `20171008_0005.pef'!
[colorin] ` PENTAX K-5' color matrix not found!
[colorin] ` PENTAX K-5' color matrix not found!
[colorin] ` PENTAX K-5' color matrix not found!
[temperature] failed to read camera white balance information from `20171008_0005.pef'!
[colorin] ` PENTAX K-5' color matrix not found!
[colorin] ` PENTAX K-5' color matrix not found!
[colorin] ` PENTAX K-5' color matrix not found!
[rawspeed] (20171008_0001.pef) void rawspeed::ByteStream::check(rawspeed::Buffer::size_type) const, line 72: Out of bounds access in ByteStream
[rawspeed] (20171008_0002.pef) void rawspeed::ByteStream::check(rawspeed::Buffer::size_type) const, line 72: Out of bounds access in ByteStream
[temperature] failed to read camera white balance information from `20171008_0001.pef'!
[temperature] failed to read camera white balance information from `20171008_0002.pef'!
allocation failed???
allocation failed???
[rawspeed] (20171008_0003.pef) void rawspeed::ByteStream::check(rawspeed::Buffer::size_type) const, line 72: Out of bounds access in ByteStream
[temperature] failed to read camera white balance information from `20171008_0003.pef'!
[rawspeed] (20171008_0004.pef) void rawspeed::ByteStream::check(rawspeed::Buffer::size_type) const, line 72: Out of bounds access in ByteStream
allocation failed???
[temperature] failed to read camera white balance information from `20171008_0004.pef'!
allocation failed???
[import_session] File /home/paolo/Immagini/Darktable/20171008_capture job/20171008_0001.pef exists.
[import_session] Testing /home/paolo/Immagini/Darktable/20171008_capture job/20171008_0002.pef.
[import_session] Testing /home/paolo/Immagini/Darktable/20171008_capture job/20171008_0003.pef.
[import_session] Testing /home/paolo/Immagini/Darktable/20171008_capture job/20171008_0004.pef.
[import_session] Testing /home/paolo/Immagini/Darktable/20171008_capture job/20171008_0005.pef.
[import_session] Using filename 20171008_0005.pef.
[rawspeed] (20171008_0005.pef) void rawspeed::ByteStream::check(rawspeed::Buffer::size_type) const, line 72: Out of bounds access in ByteStream
[temperature] failed to read camera white balance information from `20171008_0005.pef'!
[temperature] failed to read camera white balance information from `20171008_0005.pef'!
allocation failed???
[colorin] ` PENTAX K-5' color matrix not found!
[colorin] ` PENTAX K-5' color matrix not found!
[colorin] ` PENTAX K-5' color matrix not found!
[temperature] failed to read camera white balance information from `20171008_0005.pef'!
allocation failed???

Additionaly, the sw does not display any image neither present on the camera memory, neither the captured one.

History

#1 Updated by Roman Lebedev over 2 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

That is strange, the samples from RPU work fine.
Can you upload that file?

#2 Updated by Paolo Astengo over 2 years ago

I'm facing this issue only when I'm trying to use the camera connected. No problems when I'm working with a file on the PC. So, I don't have any file to upload. Would you like to have an output from "darktable -d camctl"?

#3 Updated by Roman Lebedev over 2 years ago

Paolo Astengo wrote:
Any reason why you use PEF and not DNG?
That one should definitively work.

I'm facing this issue only when I'm trying to use the camera connected. No problems when I'm working with a file on the PC. So, I don't have any file to upload. Would you like to have an output from "darktable -d camctl"?

#4 Updated by Paolo Astengo over 2 years ago

Thank you Roman, I've just tried with DNG and this avoid the error. I'm still facing some trouble with tethering, but I think that can be related to libgphoto.

I don't know if this workaround can cause this ticked to be closed, but I'll switch to DNG definitely .

Also available in: Atom PDF

Go to top