Project

General

Profile

Bug #11760

paste history stack broken

Added by Stefan Schöfegger over 1 year ago. Updated over 1 year ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
10/05/2017
Due date:
% Done:

0%

Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

copy and paste histroy stack works only the first time.

How to reproduce
Open one image in darktable. Crop and rotate picture
Goto Lighttable
Select Historystack/Copy and select only "crop and rotate"
select another image
Select Historystack/paste and seelct only "crop and rotate"
-> works as expected. crop and rotate ist added to history stack

redo with two new images
-> basecurve, sharpen, orientation is removed after paste
history stack only contains original & crop and rotate

History

#1 Updated by Roman Lebedev over 1 year ago

Stefan Schöfegger wrote:

copy and paste histroy stack works only the first time.

How to reproduce
Open one image in darktable. Crop and rotate picture
Goto Lighttable
Select Historystack/Copy and select only "crop and rotate"
select another image
Select Historystack/paste and seelct only "crop and rotate"
-> works as expected. crop and rotate ist added to history stack

redo with two new images

-> basecurve, sharpen, orientation is removed after paste

So this is the problem, to be specific?
And it only happens for the images that weren't opened in darkroom yet?

The thing is, basecurve, sharpen, orientation are not there yet,
they are only added to the history stack when the image is first
time opened in the darkroom. I suspect that pasting history
stack entry somehow interferes with that. Or maybe that is expected :/

history stack only contains original & crop and rotate

#2 Updated by Stefan Schöfegger over 1 year ago

So this is the problem, to be specific?

Yes, the problem is that existing history stack is overwritten.
And it only happens for the images that weren't opened in darkroom yet?

No, it also happens to images which have been edited before and all work is overwritten.
I don't think this can be the desired behavior.

#3 Updated by Roman Lebedev over 1 year ago

Stefan Schöfegger wrote:

[...]
Yes, the problem is that existing history stack is overwritten.

[...]
No, it also happens to images which have been edited before and all work is overwritten.
I don't think this can be the desired behavior.

Also see https://www.darktable.org/usermanual/ch02s03s07.html.php#d0e2805

#4 Updated by Stefan Schöfegger over 1 year ago

  • Status changed from New to Closed: invalid

Oh, I think I had overseen mode button.

#5 Updated by Roman Lebedev over 1 year ago

  • Target version set to 2.4.0

Also available in: Atom PDF