Project

General

Profile

Bug #11728

automatic picture information reading from RAW not working or displays inconsistent values

Added by Andreas Rathgeber almost 2 years ago. Updated almost 2 years ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
09/05/2017
Due date:
% Done:

100%

Affected Version:
git master branch
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hello,

I'm new to darktable. I recognized a few bugs. Screenshots as attachment uploaded:
In Leuchttisch vs. Dunkelkammmer:
- no Modell, Hersteller, Objektiv reading from RAW automatically read for Panasonic DMC-LX100 and DC-GH5 "Leuchttisch", while exactly this works for a Canon EOS 500D. In Dunkelkammer the values for Modell, Hersteller and Objektiv is automatically displayed.
- For Canon EOS 500D the picture height and width displays different between Leuchttisch and Dunkelkammer.

This automatic recognition for LX100 and GH5 also doesn't work for the lens correction part of the Dunkelkammer, while it does work for the EOS 500D.

Kind Regards,
Andreas Rathgeber

LX100, GH5, EOS 500D.png (546 KB) Andreas Rathgeber, 09/05/2017 09:59 PM

LX100_P1060089.RW2 - Panasonic DMC-LX100 fixed built in lens (13.2 MB) Andreas Rathgeber, 09/06/2017 01:19 PM

500D_IMG_5696.CR2 - Canon EOS 500D 18-55 mm Kit (20.3 MB) Andreas Rathgeber, 09/06/2017 01:20 PM

GH5_P1033519.RW2 - Panasonic DC-GH5 Leica 12-60 mm (23.1 MB) Andreas Rathgeber, 09/06/2017 01:20 PM

darktable-log.txt Magnifier (1.96 KB) Andreas Rathgeber, 09/06/2017 10:32 PM

History

#1 Updated by Andreas Rathgeber almost 2 years ago

Hm well if I report on the Windows pre alpha release. Is it the git master branch then?

#2 Updated by Tobias Ellinghaus almost 2 years ago

  • Status changed from New to Incomplete
  • % Done changed from 0 to 20

Yes, it is git master.

Those inconsistencies are weird. Could you upload one image for each camera so I can give it a try?

#3 Updated by Andreas Rathgeber almost 2 years ago

Yes sure. I upload them. Thanks.

#4 Updated by Peter Budai almost 2 years ago

Hi Andreas,

could you do the following:
1. remove the existing pictures from the collection
2. Close darktable
3. Launch darktable
4. Import the image in question where the EXIV data is not visible (no modell, manufacturer etc.)
5. Close darktable
6. Upload the log file which can find:
C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt

#5 Updated by Andreas Rathgeber almost 2 years ago

Hello Peter,

But wasn't DT already writing this metadata files for each picture? What todo with them? Keep?

And to have a faster result can I copy these three pictures to an own directory and open it there instead? Because the current directories contain some number of pictures (JPEG + RAW)

Bye,
Andreas

#6 Updated by Peter Budai almost 2 years ago

darktable is not touching metadata in the original image file.
It's OK to create a new folder, copy only the image files (CR2, RW2), and then do the import on this new folder/images

#7 Updated by Andreas Rathgeber almost 2 years ago

I have a slight problem right now. I can only find this path:
C:\Users\[username]\AppData\Local\Microsoft\Windows\

But then I can't find deeper this: INetCache

I searched my drives for "darktable" to no success.

#8 Updated by Andreas Rathgeber almost 2 years ago

I found it. INetCache seems a hidden directory.

#9 Updated by Tobias Ellinghaus almost 2 years ago

Could you please try again with the latest build version 2.3.0+898 (https://discuss.pixls.us/t/darktable-for-windows/4966/83). It seems your path contains umlauts which were known to cause exiv2 issues. Those should be fixed in the latest build.

#10 Updated by Andreas Rathgeber almost 2 years ago

You are right. I read this about the blanks and "Umlaute" in the path and took care to install into a directory without blanks, but then forgot the fact that also other paths would be affected.

I'm sorry for causing this extra effort to you.

#11 Updated by Tobias Ellinghaus almost 2 years ago

No worries. Just check if it's fixed in the latest build so we can close the bug.

#12 Updated by Andreas Rathgeber almost 2 years ago

Generally speaking, thanks it works now. I used the hard method and started importing the whole pciture directory with a few thousands RAW and JPEG pictures in it. Darktable hang 2 times since yesterday and I needed to kill it. But that's not of a big issue for me right now.

So thanks for your support. As next step I will try to figure out how to offer support the full implmentation of my equipment. I'm aware that other things have probably priority over this. But maybe I start with the lensfun thing ...

#13 Updated by Tobias Ellinghaus almost 2 years ago

  • % Done changed from 20 to 100
  • Status changed from Incomplete to Fixed

#14 Updated by Roman Lebedev almost 2 years ago

  • Target version set to 2.4.0

Also available in: Atom PDF