Project

General

Profile

Bug #11698

Raw black/white point artifacts

Added by Paolo Astengo about 1 month ago. Updated about 1 month ago.

Status:
Incomplete
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
-
Start date:
08/16/2017
Due date:
% Done:

20%

Affected Version:
git master branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I'm facing some issue on "Raw black/white point" module that seems to be a cause of other weird behaviors.

Changing black level 0 and 3, the image is how I expect to be, but, if I change the black levels 1 or 2, the image is somewhat strange (a sort of pixeling).
I tried to change the demosaic mode already, with no results and this seems not related to image type (I tried both NEF and PEF files).

Attached there is an image and some screenshots.

Schermata da 2017-08-16 14-26-26.resized.png (469 KB) Paolo Astengo, 08/16/2017 03:39 PM

Schermata da 2017-08-16 14-26-16.resized.png (733 KB) Paolo Astengo, 08/16/2017 03:39 PM

Schermata da 2017-08-16 14-26-34.resized.png (733 KB) Paolo Astengo, 08/16/2017 03:39 PM

_IGP6220.PEF.xmp (1.58 KB) Paolo Astengo, 08/16/2017 03:39 PM

Schermata da 2017-08-16 14-26-42.resized.png (444 KB) Paolo Astengo, 08/16/2017 03:39 PM

_IGP6220.PEF (16.6 MB) Paolo Astengo, 08/16/2017 03:39 PM

History

#1 Updated by Roman Lebedev about 1 month ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

This is Closed: invalid.

That is exactly how it should behave.
https://www.darktable.org/usermanual/ch03s04.html.php#raw_black_white_point
"Changes to the defaults are normally not required."

Why are you changing those parameters?

#2 Updated by Paolo Astengo about 1 month ago

Because this is simply a silly try to give you some hint about the issue I have in the tonemapping module and in the chromatic aberration (ticket no. #11694). :)

Also available in: Atom PDF