Project

General

Profile

Bug #11686

Unnable to use opencl (missing image support)

Added by Pedro Pimenta almost 2 years ago. Updated over 1 year ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
OpenCL
Target version:
Start date:
08/07/2017
Due date:
% Done:

0%

Affected Version:
2.2.5
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hello, when I try to launch darktable -d opencl thats what I get:

[opencl_init] found opencl runtime library 'libOpenCL'
[opencl_init] opencl library 'libOpenCL' found on your system and loaded
[opencl_init] found 1 platform
[opencl_init] found 1 device
[opencl_init] discarding device 0 `AMD CAPE VERDE (DRM 2.49.0 / 4.9.39-1-MANJARO, LLVM 4.0.1)' due to missing image support.
[opencl_init] no suitable devices found.
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF.

My GPU is a ATI Radeon HD7730. I doubt that it really doesnt have image support, so what could be the problem? Thanks in advance!

History

#1 Updated by Pedro Pimenta almost 2 years ago

edit: using Manjaro Linux on KDE, and a laptop with dual graphics.

#2 Updated by Roman Lebedev almost 2 years ago

  • Status changed from New to Closed: upstream

Pedro Pimenta wrote:

Hello, when I try to launch darktable -d opencl thats what I get:

[opencl_init] found opencl runtime library 'libOpenCL'
[opencl_init] opencl library 'libOpenCL' found on your system and loaded
[opencl_init] found 1 platform
[opencl_init] found 1 device
[opencl_init] discarding device 0 `AMD CAPE VERDE (DRM 2.49.0 / 4.9.39-1-MANJARO, LLVM 4.0.1)' due to missing image support.

https://dri.freedesktop.org/wiki/GalliumCompute/ {2D,3D} image {read,write} is TODO

[opencl_init] no suitable devices found.
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF.

My GPU is a ATI Radeon HD7730. I doubt that it really doesnt have image support, so what could be the problem? Thanks in advance!

#3 Updated by Roman Lebedev almost 2 years ago

  • Target version set to 2.4.0

#4 Updated by Ulrich Atzrott over 1 year ago

needs an update of the target version, as (at least for my Radeon HD 7750 still exisiting)

Would be great to have opencl...
___________________

darktable -d opencl
[opencl_init] opencl related configuration options:
[opencl_init]
[opencl_init] opencl: 1
[opencl_init] opencl_library: ''
[opencl_init] opencl_memory_requirement: 768
[opencl_init] opencl_memory_headroom: 300
[opencl_init] opencl_device_priority: '*/!0,*/*/*'
[opencl_init] opencl_mandatory_timeout: 200
[opencl_init] opencl_size_roundup: 16
[opencl_init] opencl_async_pixelpipe: 0
[opencl_init] opencl_synch_cache: 0
[opencl_init] opencl_number_event_handles: 25
[opencl_init] opencl_micro_nap: 1000
[opencl_init] opencl_use_pinned_memory: 0
[opencl_init] opencl_use_cpu_devices: 0
[opencl_init] opencl_avoid_atomics: 0
[opencl_init]
[opencl_init] could not find opencl runtime library 'libOpenCL'
[opencl_init] could not find opencl runtime library 'libOpenCL.so'
[opencl_init] found opencl runtime library 'libOpenCL.so.1'
[opencl_init] opencl library 'libOpenCL.so.1' found on your system and loaded
[opencl_init] found 1 platform
[opencl_init] found 1 device
[opencl_init] discarding device 0 `AMD CAPE VERDE (DRM 2.43.0 / 4.4.0-109-generic, LLVM 5.0.0)' due to missing image support.
[opencl_init] no suitable devices found.
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF.

#5 Updated by Tobias Ellinghaus over 1 year ago

Well, the problem isn't in darktable it seems, so there is nothing we can do.

#6 Updated by Roman Lebedev over 1 year ago

Ulrich Atzrott wrote:

needs an update of the target version, as (at least for my Radeon HD 7750 still exisiting)

Would be great to have opencl...

Nothing has changed since my comment #2, mesa support is still missing, and that is mesa problem, not ours.
With some more modern card(?) you might be able to use opencl from AMDGPU blob, don't know how that works.


darktable -d opencl
[opencl_init] opencl related configuration options:
[opencl_init]
[opencl_init] opencl: 1
[opencl_init] opencl_library: ''
[opencl_init] opencl_memory_requirement: 768
[opencl_init] opencl_memory_headroom: 300
[opencl_init] opencl_device_priority: '*/!0,*/*/*'
[opencl_init] opencl_mandatory_timeout: 200
[opencl_init] opencl_size_roundup: 16
[opencl_init] opencl_async_pixelpipe: 0
[opencl_init] opencl_synch_cache: 0
[opencl_init] opencl_number_event_handles: 25
[opencl_init] opencl_micro_nap: 1000
[opencl_init] opencl_use_pinned_memory: 0
[opencl_init] opencl_use_cpu_devices: 0
[opencl_init] opencl_avoid_atomics: 0
[opencl_init]
[opencl_init] could not find opencl runtime library 'libOpenCL'
[opencl_init] could not find opencl runtime library 'libOpenCL.so'
[opencl_init] found opencl runtime library 'libOpenCL.so.1'
[opencl_init] opencl library 'libOpenCL.so.1' found on your system and loaded
[opencl_init] found 1 platform
[opencl_init] found 1 device
[opencl_init] discarding device 0 `AMD CAPE VERDE (DRM 2.43.0 / 4.4.0-109-generic, LLVM 5.0.0)' due to missing image support.
[opencl_init] no suitable devices found.
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF.

Also available in: Atom PDF