Project

General

Profile

Bug #11640

Flickr integration is broken

Added by Nick Kachulin 11 months ago. Updated 4 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
06/06/2017
Due date:
% Done:

0%

Affected Version:
2.2.5
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

It seems that flickr has changed its API.
Attempt to authorize darktable opens home page instead of authorization page as it used to be.

oauth_ini.diff Magnifier (1.84 KB) Stefan Schöfegger, 11/29/2017 10:44 PM


Related issues

Related to darktable - Bug #10861: Flickr log in Duplicate 01/07/2016
Duplicated by darktable - Bug #11759: flickr authentication broken Duplicate 10/05/2017

History

#2 Updated by Rich Renomeron 11 months ago

Flickurl, the library behind the flickr integration, appears to support the new OAuth protocol:
http://librdf.org/flickcurl/api/flickcurl-auth.html. It's theoretically possible to "simply" rewrite the authentication code to do it the new way.

#3 Updated by Nick Kachulin 11 months ago

So, is's not a bug, it's apparently a feature... now I need tokens... will try to handle it these days...
Thanks!

#4 Updated by Rich Renomeron 10 months ago

After a couple of days of hacking I've been able to get part of the way there, but I seem to be running into this issue with flickcurl:

https://github.com/dajobe/flickcurl/issues/30

While it's been resolved for over two years, there has not been a proper release of flickcurl since then. It's going to take a while, but I will need to build darktable with the latest flickcurl source to make further progress.

You can see my current progress at https://github.com/rrenomeron/darktable/tree/flickcurl-oauth

#5 Updated by Nick Kachulin 10 months ago

Yeah, apparently it's been known for a couple of years...
As you can see from this ticket https://github.com/dajobe/flickcurl/issues/28
all we need to do is remove one line of code -- given that is is actually an app that is needed just once, the rest of code brush-up can be omitted.
I tried to do this hack but bumped onto my inability to create a patch that could be swallowed by `patch` without the -l option. I seem to count all the spaces several times, copy-pasted the fragment but patch < .... rejects it while patch -l did it just fine... heck..

#6 Updated by Roman Lebedev 7 months ago

#7 Updated by Roman Lebedev 7 months ago

  • Duplicated by Bug #11759: flickr authentication broken added

#8 Updated by Stefan Schöfegger 5 months ago

@ Rich Renomeron

I had a short look into it.
With info from http://librdf.org/flickcurl/api/flickcurl-auth-authenticate.html i created the ~/.flickcurl.conf file (API is in flickr.c)

[flickr]
  oauth_client_key=XXXXXXXXXXXXX
  oauth_client_secret=XXXX

and then
flickcurl oauth-create

follow instructions.

Attached is a diff that applies on your branch https://github.com/rrenomeron/darktable/tree/flickcurl-oauth for using this ini file for authentication.

Maybe it helps finding a solution

#9 Updated by Nick Kachulin 4 months ago

@ Rich Renomeron

Any progress on this?

Meanwhile I gave flickcurl another shot, applied the short "crash free" patch, went thru the auth process and got the tokens.
Still no auth from DT -- when I try to log in flickr redirects to a home page.
Now it's upon darktable I guess. Next move?

#10 Updated by Tobias Ellinghaus 4 months ago

Next move would be someone with the time and initiative to sit down and fix the code in dt. We already have exporters that use OAuth, so some boiler plate code can probably be shared, like the local webserver.

#11 Updated by Rich Renomeron 4 months ago

Nick Kachulin wrote:

@ Rich Renomeron

Any progress on this?

Not really. I've just checked in on this after many months (I've found that the Flickr web uploader works fine for my purposes). I will try to take a look at your patch in the next week or so.

If I don't make any progress in a few weeks (my C skills have atrophied over many years), I'll likely just commit what I have and see if someone else can pick up the baton.

Also available in: Atom PDF