Project

General

Profile

Bug #11606

Mac OS Crash when opening preferences

Added by Joel Charriere 12 months ago. Updated 4 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
05/10/2017
Due date:
% Done:

0%

Affected Version:
2.2.4
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Darktable for MacOS crashes every time I try to open the "preferences" window. It used to work perfectly, just started today. I tried uninstalling and reinstalling Darktable, but the problem persists. I've included the error log that my computer asks me to send to Apple. Hopefully somebody can figure this out. Thanks!

error message details.txt Magnifier - Apple Error Log (113 KB) Joel Charriere, 05/10/2017 07:40 AM

data.db (192 KB) Joel Charriere, 05/10/2017 09:15 PM

data.db - Copy with bad preset removed (192 KB) Tobias Ellinghaus, 05/11/2017 11:51 AM

History

#1 Updated by Tobias Ellinghaus 12 months ago

Do you have some strange preset names in your database? The backtrace looks a little odd so I am not completely sure what is happening there.

#2 Updated by Joel Charriere 12 months ago

If you mean Presets for modules, I only have 2 that I've made, named Film Faded Matte, and pro400H skin tones.
If that's not what you meant, I'm not sure I understood, please elaborate.

#3 Updated by Tobias Ellinghaus 12 months ago

Yes, that's what I meant. If your ~/.config/darktable/data.db isn't too big I'd like you to upload that.

#4 Updated by Joel Charriere 12 months ago

Here it is.

#5 Updated by Joel Charriere 12 months ago

You're definitely on the right track with the .config folder files, because I moved them to the trash, and when the app restarted and created new ones, it works fine again.
I put back the original library.db file and it still works.
I notice that in the new folder, there are NOT 2 files present in the old one: data.db.lock and library.db.lock

#6 Updated by Tobias Ellinghaus 12 months ago

The .lock files are just leftovers from the crash. You can safely delete them after a crash.

#7 Updated by Tobias Ellinghaus 12 months ago

So, I had a look at your data.db and it seems that there are two instances of the "Film Faded Matte" preset. One for the tone curve and one with a garbled module name (and some other issues). Can you remember if you added those inside darktable manually or if they came in from some style? Attached you will find a copy of data.db with the bad entry removed.

#8 Updated by Joel Charriere 12 months ago

Thank you Tobias!! That worked!
I replaced all the original files back in the .config folder, including the data.db file you sent and it works perfectly. My presets are back.
I had added the Film Faded matte preset by myself. I don't know how it could have appeared with a jumbled module, but, if in the future this happened again, what software would I use to to open a .db file to fix this myself?

Your help is greatly appreciated! I desperately was wanting to change keyboard shortcuts and couldn't get to them! :)

#9 Updated by Tobias Ellinghaus 12 months ago

I used `sqlite3` on the command line. There are GUI tools, too. But you need to know some SQL to fix that manually.

#10 Updated by Roman Lebedev 4 months ago

  • Target version changed from 2.4.0 to 2.6.0

Also available in: Atom PDF