Project

General

Profile

Bug #11593

Drag&drop shows icon in screen corner on Windows

Added by Tobias Ellinghaus almost 2 years ago. Updated almost 2 years ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
04/26/2017
Due date:
% Done:

0%

Affected Version:
git master branch
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When dragging from lighttable or filmstrip the drag&drop icon (either the generic or a thumbnail) is shown in the very top left corner of the screen. No cursor is shown, making it hard to place images on the map for example.

This seems to be a GTK+ bug as the same can be seen in gtk3-demo.

Upstream bug report is https://bugzilla.gnome.org/show_bug.cgi?id=781737. I am keeping this one open until it's fixed in GTK+ and as reference.

History

#1 Updated by Peter Budai almost 2 years ago

Patch has been accepted and built into GTK.
Also MSYS2 has been updated to 3.22.13: https://github.com/Alexpux/MINGW-packages/pull/2454

Just need to wait until it will be available in the repo.

#2 Updated by Peter Budai almost 2 years ago

With the latest GTK3 (3.22.14) I have tested and it is working now.

#3 Updated by Tobias Ellinghaus almost 2 years ago

  • % Done changed from 20 to 0
  • Status changed from Triaged to Closed: upstream

Confirmed.

#4 Updated by Roman Lebedev almost 2 years ago

  • Target version set to 2.4.0

Also available in: Atom PDF