Project

General

Profile

Bug #11549

H.l. reconstruction(reconstruct color) + any demosaic algorithm other than VNG4 = enormous scanline/maze artifacts

Added by Sarge Borsch about 2 years ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
03/22/2017
Due date:
% Done:

0%

Affected Version:
2.2.3
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I'm attaching an example raw file which is affected, and:
(1) 100% crop of the affected area with the settings from XMP;
(2) …same, but when demosaic is switched to AMaZE;
(3) …same, but when demosaic is switched to AMaZE and h.l. reconstruction set to Clip Highlights;
XMP with the settings I used for the photo in the end (but keep in mind that it probably references a custom denoise profile — I renamed profile from Canon G15 to use with G16);
JPG with full result with these settings.

Note that the 2nd image has artifacts (on the brightest parts).

PPG demosaic algorithm produces similar artifacts too, I didn't upload it.

"color smoothing" and "match greens" in demosaic parameters seem to not change anything at all in all of the cases I reviewed.

IMG_0070.CR2 (13.1 MB) Sarge Borsch, 03/22/2017 09:03 AM

2-IMG_0070_amaze.tif - …same, but when demosaic is switched to AMaZE (539 KB) Sarge Borsch, 03/22/2017 09:13 AM

3-IMG_0070_amaze_clip.tif - …same, but when demosaic is switched to AMaZE and h.l. reconstruction set to Clip Highlights (533 KB) Sarge Borsch, 03/22/2017 09:13 AM

1-IMG_0070_vng4.tif - 100% crop of the affected area with the settings from XMP (488 KB) Sarge Borsch, 03/22/2017 09:13 AM

IMG_0070.CR2.xmp - XMP with the settings I used for the photo in the end (17.8 KB) Sarge Borsch, 03/22/2017 09:17 AM

IMG_0070.jpg - full result with these settings (1.88 MB) Sarge Borsch, 03/22/2017 09:18 AM

vertical lines.png (211 KB) Gustavo Adolfo, 01/02/2019 04:31 AM

big brown artifacts and vertical lines.png (200 KB) Gustavo Adolfo, 01/02/2019 04:31 AM

CRW_4191.DNG.xmp (2.87 KB) Gustavo Adolfo, 01/02/2019 04:32 AM

CRW_4191.DNG (17.8 MB) Gustavo Adolfo, 01/02/2019 04:32 AM


Related issues

Duplicates darktable - Bug #10283: new "reconstruct color" in "highlight recovery" producing weird artefacts outside highlights Confirmed 01/12/2015

History

#1 Updated by Roman Lebedev about 2 years ago

  • Duplicates Bug #10283: new "reconstruct color" in "highlight recovery" producing weird artefacts outside highlights added

#2 Updated by Roman Lebedev about 2 years ago

  • Status changed from New to Duplicate

#3 Updated by Roman Lebedev about 2 years ago

  • Target version set to 2.4.0

#4 Updated by Gustavo Adolfo 6 months ago

I have big artifacts and vertical lines showing whenever I push the threshold slider to a certain point in reconstruct color mode.

Attached two crops to show the issues, the original dng and xmp file.

The symptoms seem to match this issue.

Darktable 2.7.0

Also available in: Atom PDF