Project

General

Profile

Bug #11522

Noise profile (gen-profile) script exit

Added by Dan A over 2 years ago. Updated over 2 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
02/25/2017
Due date:
% Done:

0%

Affected Version:
git master branch
System:
Fedora/RHEL
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When running the gen-profile script I've come across an issue where it starts generating a noise profile for the first image and then the script exits abruptly without any warnings/errors.

I have traced the exit to occur at the step:
$noiseprofile $pfm -c $(cat $fit) > $flat_dat 2> $curves_dat

In particular, it is the $(cat $fit) portion that seems to result in the error - for my particular file when the exit occurs the curves file has data but the flat file remains at 0 bytes.

I can run this step manually in my bash shell and it works fine. I have tried running the script under both sh and bash, and I have tried replacing $(cat $fit) with `cat $fit` which should be equivalent at least in bash.

I have tried this with scripts in my distro's version (had to patch it up to work in the first place), in the current stable, and the git repository versions. No difference in the behaviour. I have attached the files relevant to this line.

Something about this line fails and I have run out of things I can think to try (I speak pidgen bash only).

I am trying to create noise profiles for the Pentax K-70 (at present) and the Pentax K-20 (future).

gen-profile (13.9 KB) Dan A, 02/25/2017 04:53 AM

output_sample (1.76 KB) Dan A, 02/25/2017 04:54 AM

IMGP6822_curves.dat Magnifier (85 Bytes) Dan A, 02/25/2017 04:55 AM

IMGP6822.fit (124 Bytes) Dan A, 02/25/2017 04:55 AM

History

#1 Updated by Dan A over 2 years ago

Slept over it and tried one more thing, the failure is due entirely to my local path having a space character " " in the path. Renamed a folder and it works.

#2 Updated by Pascal Obry over 2 years ago

  • Status changed from New to Closed: invalid

So if all is ok I'm closing.

#3 Updated by Roman Lebedev over 2 years ago

  • Target version set to 2.4.0

Also available in: Atom PDF