Project

General

Profile

Bug #11471

Demozaicing artifacts with OpenCL

Added by Žilvinas Žaltiena over 2 years ago. Updated about 2 years ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
01/21/2017
Due date:
% Done:

0%

Affected Version:
2.2.1
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I am getting artifacts with Fuji RAF files while using Markesteijn (1 or 3 passes) with OpenCL. Artifacts are gone when OpenCL is off.

I have attached raf+xmp and png illustrating the issue. Every module is turned off if it is possible to do so. Artifacts look like offset pixel rows of certain color channels.

I am using NVIDIA 378.09 driver.

DSCF6909_gpu.png (1.52 MB) Žilvinas Žaltiena, 01/21/2017 07:50 PM

DSCF6909.RAF.xmp (7.54 KB) Žilvinas Žaltiena, 01/21/2017 07:51 PM

DSCF6909.RAF (32.2 MB) Žilvinas Žaltiena, 01/21/2017 07:51 PM

History

#1 Updated by Žilvinas Žaltiena over 2 years ago

UPDATE: This seems to be a problem/incompatibility with NVIDIA driver 378.09. Using driver 375.26 does not create such artifacts.

#2 Updated by Ulrich Pegelow about 2 years ago

  • Status changed from New to Closed: upstream

So it's obviously an upstream issue. Let's hope that this is not an indicatication of future regressions in the NVIDIA driver.

#3 Updated by Roman Lebedev about 2 years ago

  • Target version set to 2.4.0

#4 Updated by Žilvinas Žaltiena about 2 years ago

UPDATE: Works correctly with NVIDIA driver 381.09. 

Also available in: Atom PDF