Project

General

Profile

Bug #11452

Supported lens does not appear as option in Lens Correction

Added by Paul Grinberg over 2 years ago. Updated over 2 years ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
01/12/2017
Due date:
% Done:

0%

Affected Version:
2.2.1
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I am running Darktable on PCLinuxOS (RPM provided by distro), but I have the same behavior even for my own build of Darktable 2.2.1. When I run

    exiv2 -pt DSC_4679.NEF | grep -ai lens

I get the expected lens description "Tamron AF 18-270mm F/3.5-6.3 Di II VC PZD", and I get the expected make and model, which is Nikon D3300. As I understand the lensfun database, the slr-tamron.xml file has an entry for this lens. Yet, it does not appear in the list of known Tamron lenses.

I have read lensfun and darktable documentation related to "lens not detected", but I think it should be working. Am I missing something or is this a bug?

History

#1 Updated by Roman Lebedev over 2 years ago

  • Status changed from New to Incomplete
  • % Done changed from 0 to 20

Paul Grinberg wrote:

I am running Darktable on PCLinuxOS (RPM provided by distro), but I have the same behavior even for my own build of Darktable 2.2.1. When I run
[...]
I get the expected lens description "Tamron AF 18-270mm F/3.5-6.3 Di II VC PZD", and I get the expected make and model, which is Nikon D3300. As I understand the lensfun database,

the slr-tamron.xml file has an entry for this lens. Yet, it does not appear in the list of known Tamron lenses.

Does the slr-tamron.xml file on your system have "<model>Tamron AF 18-270mm f/3.5-6.3 Di II VC PZD</model>" ?

I have read lensfun and darktable documentation related to "lens not detected", but I think it should be working. Am I missing something or is this a bug?

#2 Updated by Paul Grinberg over 2 years ago

Roman Lebedev wrote:

Does the slr-tamron.xml file on your system have "<model>Tamron AF 18-270mm f/3.5-6.3 Di II VC PZD</model>" ?

Yes it does.

#3 Updated by Roman Lebedev over 2 years ago

Please show screenshot of both the image information module and lens correction module (and reset it first), in expanded state.

#4 Updated by Roman Lebedev over 2 years ago

  • Status changed from Incomplete to Closed: upstream
  • % Done changed from 20 to 0
[17:55:41] <Mimir> does it not show because of a cropfactor mismatch?
[17:56:58] <LebedevRI> if the lf calibration is for crop body, and it is being used on a crop that is closer to 1.0, then yes
[17:57:07] <Mimir> D3300 is listed with 1.523   the lens definition specifies 1.613
[17:58:21] <Mimir> i think i had a similar problem with the cropfactor for the K-r a long time ago

https://github.com/lensfun/lensfun/blob/d5e776d904d22a69dabf2f1c3d034658151de329/data/db/slr-nikon.xml#L259
https://github.com/lensfun/lensfun/blob/d716850326274948018beb7d9dec13eb841ec91a/data/db/slr-tamron.xml#L511

I think you may need to recalibrate it...
https://github.com/lensfun/lensfun/issues

#5 Updated by Roman Lebedev over 2 years ago

  • Target version set to 2.4.0

Also available in: Atom PDF