Project

General

Profile

Bug #11434

darkroom artefacts with local laplacian filter in local contrast module with opencl active

Added by Christian Kanzian 3 months ago. Updated about 2 months ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
OpenCL
Target version:
Start date:
01/05/2017
Due date:
% Done:

100%

Affected Version:
git master branch
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi,

I get 'artefacts' in darkroom mode (see screenshot) on the right hand side of the image preview,
  • if the local contrast module is set to "local laplacian filter",
  • I zoom in and out heavily
  • with opencl active. If I switch off opencl there are no artefacts.

However, I can only reproduce this with the attached RAW and xmp. So it must be related to the other modules used?

Christian

bug_artefacts_darkroom.png (1.45 MB) Christian Kanzian, 01/05/2017 03:42 PM

IMGP31439.DNG.xmp (5.43 KB) Christian Kanzian, 01/05/2017 03:42 PM

IMGP31439.DNG (20.6 MB) Christian Kanzian, 01/05/2017 03:45 PM

20161226_IMGP31439_0_dt.jpg (381 KB) Christian Kanzian, 01/05/2017 09:28 PM

History

#1 Updated by Roman Lebedev 3 months ago

  • Category set to OpenCL

#2 Updated by Christian Kanzian 3 months ago

Oh, export is also affected ...

#3 Updated by Christian Kanzian about 2 months ago

I have no issues anymore since commit a770a577fe7adbcd5b2731a3dd80ccac4d7ea2d8

Thanks!

#4 Updated by Pascal Obry about 2 months ago

  • % Done changed from 0 to 100
  • Target version set to 2.4.0
  • Status changed from New to Fixed

Thanks for confirming. I'm closing this issue then.

Also available in: Atom PDF