Project

General

Profile

Feature #11431

Usermanual needs to explain about library lock

Added by Bruce Williams 12 months ago. Updated 12 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Usermanual
Target version:
-
Start date:
01/04/2017
Due date:
% Done:

0%

Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi all,
Don't know what happened lat light. System was running fine yesterday morning.
Last night, my M drive (an NTFS partition I share with Win7/64, and where my folder full of photos lives) suddenly decided that it was going to take ages to mount. Use to happen instantaneously.
And on top of that, when I'd go to fire up dt, I'd get an error message (see attached image), which I think simply means "there's already an instance of dt running" (I'm new to linux, but I think that is what it's saying).
And this morning, even though M drive SAYS it's mounted, and even though dt (which eventually decided to launch) is showing me thumbnails, whenever I try to see a fullscreen preview of an image (hitting Z key), I get the dead man icon.
Any thoughts as to what might be happening here?
Thanks in advance.

Screenshot (edit).png (27.9 KB) Bruce Williams, 01/04/2017 10:17 PM

History

#1 Updated by Roman Lebedev 12 months ago

  • System changed from Ubuntu to all
  • Affected Version changed from 2.2.1 to git master branch
  • Category changed from General to Usermanual
  • Subject changed from Can anyone explain this error? to Usermanual needs to explain about library lock
  • Tracker changed from Bug to Feature

@Bruce Williams it means that some process with that pid is alive on the system.
If dt with that library is not running, it means it was not closed properly.

#2 Updated by Tobias Ellinghaus 12 months ago

In which case you can delete the .lock file next to the .db file mentioned in the dialog.
About images resulting in skulls, can you open the files in darkroom?

Also available in: Atom PDF