Project

General

Profile

Bug #11426

Newly imported film rolls don't appear in collection module

Added by Richard Wonka over 3 years ago. Updated almost 3 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
-
Start date:
01/04/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.1
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When importing from camera, the import appears to work normally and images get copied to the destination directory, but the images do not (always) appear in the lighttable, even though the collection module claims to show the new film roll and any newly created film rolls do not appear in the collection module.

After restarting dt, they are listed as expected.

Screenshot from 2017-05-10 18.33.50.png (151 KB) Screenshot from 2017-05-10 18.33.50.png full view after import Richard Wonka, 05/10/2017 02:34 PM
Screenshot from 2017-05-10 18.36.49.png (51.5 KB) Screenshot from 2017-05-10 18.36.49.png collection module after reset does not show new film roll Richard Wonka, 05/10/2017 02:38 PM
Screenshot from 2017-05-10 18.39.21.png (32.8 KB) Screenshot from 2017-05-10 18.39.21.png new film roll shows up as expected after restarting dt Richard Wonka, 05/10/2017 02:40 PM

History

#1 Updated by Pascal Obry about 3 years ago

This is working for me on a regular basis. Isn't this a filter issue?

Maybe you can run dt on command line with -d sql to see if something is wrong there.

#2 Updated by Richard Wonka about 3 years ago

I think I found out what is happening.

I import to $(PICTURES_FOLDER)/$(EXIF_YEAR)/$(EXIF_YEAR)-$(EXIF-MONTH)-$(EXIF_DAY)/<filename>

after import, darktable tries to show me the film roll $(YEAR)-$(MONTH)-$(DAY)

#3 Updated by Richard Wonka almost 3 years ago

Pascal Obry wrote:

This is working for me on a regular basis. Isn't this a filter issue?

Maybe you can run dt on command line with -d sql to see if something is wrong there.

So, yes, it appears to be a filter issue. dt sets the default filter to the date of import, so when pictures are imported that were not taken $(TODAY), the filter misses them.

#4 Updated by Richard Wonka almost 3 years ago

Here is an example:

I just imported images from a few days ago.

after import, the screen looks like the attached screenshot: an empty light table

The autogenerated filter that td tries to look at is

/home/richard/Pictures/2017/2017-05-10_wine tasting

So it applies the current date instead of the exif date when creating the filter.

The newly created film roll does not show up in the list of film rolls when I reset the collection module, see screenshot 2

after restarting dt, the new film roll shows up as expected in the collection module (look for "wine tasting" in the next screenshot.

#5 Updated by Richard Wonka almost 3 years ago

here is the collection module after restarting dt

Also available in: Atom PDF

Go to top