Project

General

Profile

Bug #11409

Lens Correction won't work with LeicaQ in version 2.2.

Added by Pierre Poulain about 3 years ago. Updated about 3 years ago.

Status:
Incomplete
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
01/01/2017
Due date:
% Done:

20%

Estimated time:
Affected Version:
2.2.0
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

The Lens Correction module was working with the LeicaQ on Manjaro Linux, KDE, until the update to version 2.2. The camera is not in the Lensfun database but it was possible to select a generic profile manually and to aply a correction. Now the module seems to be broken, it shows the correct lens (28 mm / 1.7) but I cannot change nothing and activating / desactivating the preset does not change anything either.
I have check and my Lensfun database and dependancies are installed well. Maybe there is something to do with the fact that verions 2.2 has - if am not wrong - "reverted to a simple lensfun database search" ?
I add a DNG file to check.

History

#1 Updated by Roman Lebedev about 3 years ago

  • hardware architecture set to amd64/x86
  • bitness set to 64-bit
  • System set to other GNU/Linux
  • Affected Version set to 2.2.0
  • % Done changed from 0 to 20
  • Status changed from New to Incomplete
  • Project changed from website to darktable

Pierre Poulain wrote:

The Lens Correction module was working with the LeicaQ on Manjaro Linux, KDE, until the update to version 2.2.

The camera is not in the Lensfun database

That is the key problem here. Get it added https://github.com/lensfun/lensfun/issues

but it was possible to select a generic profile manually and to aply a correction. Now the module seems to be broken, it shows the correct lens (28 mm / 1.7) but I cannot change nothing and activating / desactivating the preset does not change anything either.
I have check and my Lensfun database and dependancies are installed well. Maybe there is something to do with the fact that verions 2.2 has - if am not wrong - "reverted to a simple lensfun database search" ?

I add a DNG file to check.

I guess it did not get attached.

#2 Updated by Pierre Poulain about 3 years ago

I undertand the "key issue". I'll submit it to the Lensfun database. But it doesn't change the fact that the Lens module worked before updating to version 2.2. does it ?
I am trying to (re)upload the file... Hope I'll do it well this time (Isee the file selected but on it's right it says "Request Entity"... not sure to understand what it means. Anyway, Thanks.

#3 Updated by Roman Lebedev about 3 years ago

Pierre Poulain wrote:

I am trying to (re)upload the file... Hope I'll do it well this time (Isee the file selected but on it's right it says "Request Entity"... not sure to understand what it means. Anyway, Thanks.

Is that file bigger than ~49Mb? If yes, upload somewhere else and paste the link

#4 Updated by Pierre Poulain about 3 years ago

Well, it's closed to 49Mb. It's 41.1 Mb.
Here is the link : https://owncloud.oinais.org/index.php/s/QDSuUknG7tS8iJK
Thanks again

Also available in: Atom PDF

Go to top