Project

General

Profile

Bug #11384

Preset Menu width bug on Fedora 25 using Wayland

Added by Ari El over 2 years ago. Updated over 2 years ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
12/23/2016
Due date:
% Done:

0%

Affected Version:
2.2.0rc3
System:
Fedora/RHEL
bitness:
64-bit
hardware architecture:
amd64/x86

Description

There is a GUI glitch in darktable 2.2 release candidates, where the "Preset" menu in every module (the one displayed when pressing the small "|||" icon shows up but it is so narrow that it is unusable (the content can't be read).

See attached screenshot.

In fact the glitch happens in all "Preset" menus of both Darkroom and Lighttable modes. All modules are affected in Darkroom mode, and in Lightroom all side panels that contain the "Preset" icon are affected

Building current 2.2 release candidate from GIT under Fedora 25, default Fedora 25 install.

Darktable-2.2rC3-Preset-Menu-Width-Bug.png (29.1 KB) Ari El, 12/23/2016 08:04 PM

Darktable-2.2rC3-Preset-Menu-Width-Bug-ThemeDebugMode.png (74.7 KB) Ari El, 12/24/2016 09:24 PM

History

#1 Updated by Tobias Ellinghaus over 2 years ago

What version of GTK3 do you have installed? And could you try creating an empty ~/.config/darktable/darktable.css to force GTK to use its default theme (you will see some red borders in darktable if that worked). Does the preset list look right then?

#2 Updated by Ari El over 2 years ago

Gnome: Version 3.22.2
Installed Packages
Name : gtk3
Arch : x86_64
Epoch : 0
Version : 3.22.5
Release : 1.fc25
Size : 17 M
Repo : @System
From repo : updates

I created the empty darktable.css file. Darktable launches with giant fonts and icons and the 'preset' submenus look worse, they "open" but show a tiny horizontal bar with the same very narrow width as show in the first attachment, but with one addition problem: besides being very narrow in width, the vertical length of the submenu is just a few pixes so the content can't be seen at all.
Screenshot attached (the "menu" is the tiny horizontal bar inside the yellow marker I added)

I'm using the default adwaita theme in gnome-shell in dark mode. Also tested in regular (non-dark) mode and same issue.

This is using the default Fedora 25 login which is wayland. Will test again but on an Xorg session and report back

#3 Updated by Ari El over 2 years ago

When using Gnome on Xorg, the issue is gone.

Works OK both launching darktable 2.2RC3 normally, and when launching it with an empty darktable.css file, the preset menus display properly (I still see giant icons and text when using the empty css file but the preset menus open up an display the full content).

So this seems to be a Wayland-specific issue of DT2.2. Note that I have been using DT2.0 daily on this same fedora install on the default Wayland session for about a month without any problem. So it seems a DT2.2 problem.

Will stay on Xorg so I can continue testing RC3 but I'd rather go back to Wayland once this is fixed.

#4 Updated by Tobias Ellinghaus over 2 years ago

  • Subject changed from Preset Menu width bug on Fedora 25 (darktable 2.2RC3) to Preset Menu width bug on Fedora 25 using Wayland
  • Target version deleted (Candidate for next major release)
  • Status changed from New to Closed: upstream

The only relevant commit related to those popups is 42e7923fcfc16aaff88aaa3fec42b7a4c82b199d. To me that looks like a bug in GTK.

#5 Updated by Roman Lebedev over 2 years ago

  • Target version set to 2.4.0

Also available in: Atom PDF