Project

General

Profile

Bug #11383

Artefacts in zoomed out view with lanczos3 and lens correction

Added by Žilvinas Žaltiena over 1 year ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
-
Start date:
12/22/2016
Due date:
% Done:

0%

Affected Version:
2.2.0rc3
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I am getting artefacts (black dots with halos of various colour) with certain high contrast images in zoomed out view when lens correction is used with lanczos3. lanczos2 is ok. Artefacts disappear when I zoom in enough. opencl on/off doesn't affect them.

I have attached raf+xmp and screenshots how it looks on my system. Look at branches around the sun or at the branches near middle bottom of image. My display is 1920x1200, so take into account when trying to reproduce it on higher resolution display.

Note that lens correction module has corrections set to none (for debugging), but it has scale left at default 1.002 for module to have something to do. If I set it to 1.000 and leave other lens corrections off, artefacts disappear. They also disappear if "demosaicing for zoomed out darkroom mode" is set to "bilinear".

I thought it was ringing of lanczos3, but downsized exported images do not have these artefacts.

lanczos3.png (2.59 MB) Žilvinas Žaltiena, 12/22/2016 07:10 PM

lanczos2.png (2.44 MB) Žilvinas Žaltiena, 12/22/2016 07:10 PM

DSCF1031.RAF.xmp (39 KB) Žilvinas Žaltiena, 12/22/2016 07:21 PM

DSCF1031.RAF (32.3 MB) Žilvinas Žaltiena, 12/22/2016 07:21 PM

Also available in: Atom PDF