Project

General

Profile

Camera Support #11369

Unable to open Fujifilm X-T2 RAF files

Added by Guido Bartoli about 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Medium
Assignee:
-
Category:
Darkroom
Target version:
Start date:
12/17/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.0rc3

Description

Hi,
I'm currently having problems developing files shot with Fujifilm X-T2.
The import process works fine, every RAF file is imported into the film roll, but as soon as I use the darkroom to develop one, I receive this error message:

failed to read camera white balance information from 'FUJI352.RAF'!
The panel freezes stuck with the lighttable view and develop modules cannot be used. The only way is to click on lighttable to return the original view, where the image preview is correctly displayed but no image can be developed.

I attached one of this image, can anyone reproduce this problem?

I'm currently switching from Lightroom to DarkTable, but my main camera is the Fujifilm X-T2... if it cannot work on its RAW files, it would be a big issue for me! :(

Thanks,
Guido

FUJI1352.RAF (21.8 MB) FUJI1352.RAF Test image Guido Bartoli, 12/17/2016 09:20 PM

Related issues

Is duplicate of darktable - Camera Support #10934: Fujifilm X-Pro2 SupportFixed02/27/2016

History

#1 Updated by Roman Lebedev about 3 years ago

Guido Bartoli wrote:

Is that new fuji compressed raw? #10934 says that compression is not supported as of yet.

#2 Updated by Guido Bartoli about 3 years ago

Roman Lebedev wrote:

Guido Bartoli wrote:

Is that new fuji compressed raw? #10934 says that compression is not supported as of yet.

Yes, that was it, I checked into options and it was enabled. Uncompressed RAF are correctly developed, many thanks! :)

As a side note, regarding the state of Fujifilm Film Simulation from RAW files, is this still planned for 2.2.0 release? (https://redmine.darktable.org/issues/11017)

#3 Updated by Roman Lebedev about 3 years ago

#4 Updated by Roman Lebedev about 3 years ago

  • Status changed from New to Duplicate

Guido Bartoli wrote:

Roman Lebedev wrote:

Guido Bartoli wrote:

Is that new fuji compressed raw? #10934 says that compression is not supported as of yet.

Yes, that was it, I checked into options and it was enabled. Uncompressed RAF are correctly developed, many thanks! :)

Some day, a support for compressed fuji raw files will be implemented.

As a side note, regarding the state of Fujifilm Film Simulation from RAW files, is this still planned for 2.2.0 release? (https://redmine.darktable.org/issues/11017)

See third comment in that issue, i think it is pretty self-explanatory. Besides since you are reporting this from 2.2.0rc3, you can try it :)

Also available in: Atom PDF

Go to top