Project

General

Profile

Bug #11365

Style with lens correction do not adjust to exif data

Added by Torsten Woertwein about 3 years ago. Updated 8 months ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
12/15/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.7
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Styles which include a presets for 'lens correction' do not adjust if they are applied on images which share not the same lens settings. I would expect that the lens correction module would adjust its settings for the images it is applied on (focal length, aperture, ...). That does not happen and produces wrongly corrected images.


Related issues

Is duplicate of darktable - Feature #10425: Lens IOP: better iteraction between autodetection and user-set paramsNew04/19/2015

History

#1 Updated by Roman Lebedev about 3 years ago

  • Is duplicate of Feature #10425: Lens IOP: better iteraction between autodetection and user-set params added

#2 Updated by Roman Lebedev about 3 years ago

  • Status changed from New to Closed: invalid

Torsten Woertwein wrote:

Styles which include a presets for 'lens correction' do not adjust if they are applied on images which share not the same lens settings.

Yes they do, but only if you did not change anything from the parameters you got from freshly-reset lens correction module.
I have covered this topic numerous times in maillists.

I would expect that the lens correction module would adjust its settings for the images it is applied on (focal length, aperture, ...). That does not happen and produces wrongly corrected images.

#3 Updated by Roman Lebedev about 3 years ago

  • Target version set to 2.2.0

#4 Updated by Torsten Woertwein about 3 years ago

Roman Lebedev wrote:

Torsten Woertwein wrote:

Styles which include a presets for 'lens correction' do not adjust if they are applied on images which share not the same lens settings.

Yes they do, but only if you did not change anything from the parameters you got from freshly-reset lens correction module.

but it should be able to change the type of correction (vignetting, TCA, geometry) without losing the 'auto-adjust ability'

#5 Updated by edward mckim 8 months ago

I tried to do a minor vertical perspective correction, it doesn't work because the picture is already highly stretched before I can get the line of the wall strait: https://hireessaywriter.org/.

Also available in: Atom PDF

Go to top