Project

General

Profile

Bug #11360

local copy searches for original file during export

Added by Johannes Hanika about 3 years ago. Updated about 3 years ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
12/13/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2.0rc3
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

when using the 'local copy' feature to work on images on a laptop without the external drive attached, it seems dt still looks for the original during export:

[xmp_attach] /tmp/img_0013.jpg: caught exiv2 exception '/media/[..]/IMG_0860.CR2: Failed to open the data source: No such file or directory (errno = 2)'
[export_job] exported to `/tmp/img_0013.jpg'

note that the export finishes just fine, only the xmp data seems to be missing (so i guess it's a minor issue and easy to fix, i just put it here so i don't forget).

Associated revisions

Revision acaa267d (diff)
Added by Johannes Hanika about 3 years ago

xmp in exported files: work with local copies. fixes #11360

Revision 9fc371bc (diff)
Added by Johannes Hanika about 3 years ago

xmp in exported files: work with local copies. fixes #11360

History

#1 Updated by Pascal Obry about 3 years ago

  • Target version set to Future

Probably easy to fix indeed. Feel free to reassign to me if you like.

#2 Updated by Johannes Hanika about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Fixed

#3 Updated by Roman Lebedev about 3 years ago

  • Target version changed from Future to 2.2.0

Also available in: Atom PDF

Go to top