Project

General

Profile

Bug #11281

Wrong thumbnails on reimport

Added by Filip Bunkens over 3 years ago. Updated over 3 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
-
Start date:
11/02/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

During the troubleshooting of a problem with a corrupt raw file, that caused DT to freeze everytime I tried to load that photo, (I'll file another bug report for that issue), I had to reimport several folders. The photos are now shown with a wrong thumbnail (from another shoot) that changes depending on the zoom level. When I open the file itself the thumbnail gets corrected again.

I saw some other bugreports on this issue over the years, but they all are solved at that time. As I'm using git version (release.2.1.0.r2127.g3c9b03d-1) from the AUR in Arch Linux. I thought it is still worth mentioning.

How to reproduce:

- Delete several folders from the library
- Restart DT (I think this is optional)
- import one folder you deleted
- import another folder you deleted
- watch the magic happen.

History

#1 Updated by Tobias Ellinghaus over 3 years ago

Did you delete/restore the library.db when removing the files or earlier? It might be that you have left over thumbnails in the cache for images with an ID bigger than the biggest one in the current library. So when importing a folder those IDs are used and darktable finds the stale cached thumbs.

#2 Updated by Filip Bunkens over 3 years ago

When deleting the cache in ~/.cache/darktable/ this solves the issue.

Suggestion, it could be nice to have a rebuild thumbnails button somewhere.

#3 Updated by Filip Bunkens over 3 years ago

I did not delete nor restore the library.db.

I just removed photos from the library and added them again later.
It does seem indeed that there is somewhere a cache issue with ID's

Also available in: Atom PDF

Go to top