Project

General

Profile

Bug #11278

Give user a choice between HSV and HSL in some filters

Added by Mariusz Jaskółka over 3 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
10/31/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.7
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

It seems that in some filters (LEVELS filter is an example) you use HSV color space while changing e.g lightness/brightness/value (or how one want to call this). It is causing image to be oversaturated even when user do not want to change saturation at all. For example:

HSL is white while HSV is fully red.

Using HSL or Lab could solve this problem. The best option would be giving user a choice between those. I think most of them want to use HSL even if they do not understand what color space is.

It could be even a bug - HSV is far worse than HSL/Lab in most scenarios in image processing. One could easily quote some theses that claims that fact.

PS: sorry for my English.

DSC00806.jpg (288 KB) DSC00806.jpg Mariusz Jaskółka, 10/31/2016 04:42 PM
Capture.PNG (1.6 MB) Capture.PNG Mariusz Jaskółka, 10/31/2016 04:43 PM

History

#1 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

All modules between input color profile and output color profile are using CIE Lab color space.
levels module is using lab.

You may want to provide specific samples which show what the problem is, exactly.

#2 Updated by Mariusz Jaskółka over 3 years ago

ok. I've attached oryginal sample grass image & screen with darktable levels filter result and GIMP levels filter result. 8-bit JPG to give GIMP a chance. I've noticed several times that darktable levels filter is unusable for me as its output is way oversaturated. Tone curve does the same think. Of course example is exaggerated just to show this effect. It might be very subjective but giving user a choice would be great.

Additionally - I am wondering if every filter is using the same CIE Lab color space, then why increasing exposure (exposure filter) gives completely different output than dragging white point handler left (levels filter). From my experience it should give the same output in the same color space (just multiply lightness by const factor). Are you sure exposure does not work in RGB?

#3 Updated by Roman Lebedev over 3 years ago

Mariusz Jaskółka wrote:

ok. I've attached oryginal sample grass image & screen with darktable levels filter result and GIMP levels filter result. 8-bit JPG to give GIMP a chance. I've noticed several times that darktable levels filter is unusable for me as its output is way oversaturated. Tone curve does the same think. Of course example is exaggerated just to show this effect. It might be very subjective but giving user a choice would be great.

Is your monitor profiled?
Do you use proper monitor ICC in both the darktable and gimp?
What does darktable-cmstest say? (show all the output)

Additionally - I am wondering if every filter is using the same CIE Lab color space,

All modules between input color profile and output color profile are using CIE Lab color space.
levels module is using lab.

then why increasing exposure (exposure filter) gives completely different output than dragging white point handler left (levels filter). From my experience it should give the same output in the same color space (just multiply lightness by const factor). Are you sure exposure does not work in RGB?

Are you sure exposure module is between input color profile and output color profile?
Because it is not.

#4 Updated by Mariusz Jaskółka over 3 years ago

Ok, I understand now why exposure works "better".

I do not use any ICC profile neither in darktable nor in gimp or OS-wide - I heve ordinary Samsung monitor and have no any profiling-device. Output from darktable-cmstest:

this executable was built with colord support enabled
darktable itself was built with colord support enabled

DVI-I-0 the X atom and colord returned the same profile
X atom: _ICC_PROFILE (0 bytes)
description: (none)
colord: "(none)"
description: (file not found)

HDMI-0 the X atom and colord returned the same profile
X atom: _ICC_PROFILE_1 (0 bytes)
description: (none)
colord: "(none)"
description: (file not found)

Better check your system setup
- some monitors lacked a profile
You may experience inconsistent color rendition between color managed applications

#5 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid
  • Tracker changed from Feature to Bug

Mariusz Jaskółka wrote:

Ok, I understand now why exposure works "better".

I do not use any ICC profile neither in darktable nor in gimp or OS-wide - I heve ordinary Samsung monitor and have no any profiling-device. Output from darktable-cmstest:

this executable was built with colord support enabled
darktable itself was built with colord support enabled

DVI-I-0 the X atom and colord returned the same profile
X atom: _ICC_PROFILE (0 bytes)
description: (none)
colord: "(none)"
description: (file not found)

HDMI-0 the X atom and colord returned the same profile
X atom: _ICC_PROFILE_1 (0 bytes)
description: (none)
colord: "(none)"
description: (file not found)

Better check your system setup
- some monitors lacked a profile
You may experience inconsistent color rendition between color managed applications

I think the faulty part is painfully clear here.
You just can't not have a properly color-manged display and talk about the color at the same time.
As for HSV/HSL, that is just wrong, since lab is better.

#6 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top