Project

General

Profile

Bug #11249

Display scaling on OS X b0rked in current master

Added by Moritz Moeller over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
10/20/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

See screenshots. This is on a 12" Retina MacBook Pro with Preferences->Display set to 'More Space'.


Related issues

Is duplicate of darktable - Bug #11185: Gtk 3.22 supportClosed: invalid09/29/2016

Is duplicate of darktable - Bug #10976: GTK 3.20 ThemeFixed04/03/2016

Is duplicate of darktable - Bug #10990: Button/icon sizes too large with GTK 3.20Duplicate04/10/2016

Is duplicate of darktable - Bug #10988: GTK 3.20 compatibility problemsDuplicate04/10/2016

History

#1 Updated by Roman Lebedev over 3 years ago

  • Status changed from New to Duplicate

That is classical symptom of gtk upgrade.
You need to rebuild darktable against the current version of gt.

#2 Updated by Roman Lebedev over 3 years ago

  • Is duplicate of Bug #11185: Gtk 3.22 support added

#3 Updated by Roman Lebedev over 3 years ago

  • Is duplicate of Bug #10976: GTK 3.20 Theme added

#4 Updated by Roman Lebedev over 3 years ago

  • Is duplicate of Bug #10990: Button/icon sizes too large with GTK 3.20 added

#5 Updated by Roman Lebedev over 3 years ago

  • Is duplicate of Bug #10988: GTK 3.20 compatibility problems added

#6 Updated by Moritz Moeller over 3 years ago

Note: the images were taken with screen_dpi_overwrite=72.
Attached is a 3rd image taken with screen_dpi_overwrite=-1.0. At this setting DT is unusable.

#7 Updated by Roman Lebedev over 3 years ago

Hint: these red borders are the sign of css issue. I have already stated what the fix is.

#8 Updated by Moritz Moeller over 3 years ago

Rebuilding against latest GTK solves the scaling of display elements. Thanks, Roman!

The windows is still too big for the screen though. I file a separate bug and this one can be closed.

#9 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top