Project

General

Profile

Bug #11196

Keyboard entry in any multi-functional pop-up below a slider Mac OSX

Added by Graham Lambert over 3 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
10/05/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.5
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

2 issues in fact that may be related for keyboard and mouse handling on a MACbook Pro

1: It is not possible to enter numbers from the keyboard whilst using any of the multi-functional pop-ups below any slider (that I have tried). The mouse works fine, just as it does with Linux, but I cannot enter data from the keyboard. The vertical marker appears on the right hand side where characters would normally appear, it flashes for a couple of seconds and then disappears, as if there is no communication between the module and the keyboard (and so the module dose not continue to wait for keyboard input - my guess).

2: Dropdown menus drop a menu on the first mouse click on the icon for the menu, but it is not possible to select a menu item without first moving the mouse off the menu frame, and the back over the frame. Then the menu items become highlighted and it is possible to select an item. This happens with the image magnification menu, right of the preview panel, and the various "multiple instance actions" menus for the editing modules. Again it seems that a signal is expected that indicates that the mouse is over a menu but does not get seen until the mouse is moved off the module and back over it again. (something like not getting the focus directly).

Architecture:
MacBook Pro OS-X Yosemite
16Gb
1Tb disk

either
used closed with EIZO monitor via thunderbolt/display port, and wireless keyboard and mouse over bluetooth.
or
open with native keyboard and tracker/mousepad

This occurs on Dt 2.0.5 and 2.0.6. I have not checked earlier versions

I have an older version of dt running on Suse 12.3 and this behaves correctly (pity Apple do not understand that you can click a mouse wheel :))
I use the later versions of Dt on the MAC due to update issues on my current Linux setup.

History

#1 Updated by Simon Rothen over 3 years ago

Issue 1 is a duplicate of Bug #11073
This happens also in version 2.0.7 (i've only tried 2.0.6 and 2.0.7)
All mentioned versions (2.0.5, 2.0.6 and 2.0.7) work well on linux.
I'm new to to the mac world and have been using darktable on linux for a year

macOS 10.12.1 - iMac 21.5, Mid 2011

#2 Updated by Ben Beasley over 3 years ago

As noted in Bug #11073, I’m also experiencing Issue 1 on Linux (Fedora 25). I am not experiencing Issue 2 there, though.

#3 Updated by Roman Lebedev over 3 years ago

  • Status changed from New to Closed: invalid

Issue 1 is a duplicate of Bug #11073
Issue 2 is supposedly fixed in 2.2rc

#4 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top