Project

General

Profile

Bug #11192

DNG from NEF HDR stack DT returns "...file color matrix not found"

Added by Alex Mozheiko over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
10/02/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.6
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I uses HDR button to merge a stack of *.RAW shots taken with Nikon 1 J1 at various exposure. After creating an HDR *.DNG file, DT pushes out 'NIKON CORPORATION NIKON 1 J1' color matrix not found"
Disregarding this message, the DNG file can be opened in the darkroom mode and processed. When it comes to the White Balance tool, the values are off the normally expected.
temperature - 25000 (at its max value)
red - 2,000
green - 1,000
blue - 1,500
Moving the sliders to the expected (real) values deliberately shifts the tint.
I'm using custom Color Input Profile calibrated specifically for my Nikon 1 J1 camera with ColorCheckerSG target and custom basecurve as well. However this dies not seem to influence the issue as the image tint is mostly controlled in this case by the wrong white balance value.

My DT version is 2.0.6+dirty, however exactly the same behaviour happens in 2.0.6 from stable repository.

I noticed that the image information in the DNG is "model" = "NIKON 1 J1" while original NEF is "model" = "1 J1" and the DNG "maker" = "NIKON CORPORATION" vs NEF "maker" = "Nikon"
Unfortunately, I failed to manipulate EXIF in any of my HDR DNGs to try aligning the information manually.

Could you, please, recommend any solution/workaround?


Related issues

Is duplicate of darktable - Bug #11108: Cameras.xml name "de-"mangling is broken, especially for nikonFixed08/10/2016

History

#1 Updated by Alex Mozheiko over 3 years ago

I used HDR button to merge a stack of *.RAW shots taken with Nikon 1 J1 at various exposure. After creating an HDR *.DNG file, DT pushes out 'NIKON CORPORATION NIKON 1 J1' color matrix not found"
Disregarding this message, the DNG file can be opened in the darkroom mode and processed. When it comes to the White Balance tool, the values are off the normally expected.
temperature - 25000 (at its max value)
red - 2,000
green - 1,000
blue - 1,500
Moving the sliders to the expected (real) values deliberately shifts the tint.
I'm using custom Color Input Profile calibrated specifically for my Nikon 1 J1 camera with ColorCheckerSG target and custom basecurve as well. However this does not seem to influence the issue as the image tint is mostly controlled, in this case, by the wrong white balance value.

My DT version is 2.0.6+dirty, however exactly the same behaviour happens in 2.0.6 from stable repository.

I noticed that the image information in the DNG is "model" = "NIKON 1 J1" while original NEF is "model" = "1 J1" and the DNG "maker" = "NIKON CORPORATION" vs NEF "maker" = "Nikon"
Unfortunately, I failed to manipulate EXIF in any of my HDR DNGs to try aligning the information manually.

Could you, please, recommend any solution/workaround?

#2 Updated by Roman Lebedev over 3 years ago

  • Is duplicate of Bug #11108: Cameras.xml name "de-"mangling is broken, especially for nikon added

#3 Updated by Roman Lebedev over 3 years ago

  • Status changed from New to Duplicate

#4 Updated by Roman Lebedev over 3 years ago

  • Target version changed from Candidate for next major release to 2.2.0

Also available in: Atom PDF

Go to top