Project

General

Profile

Bug #11188

Visual styling broken on Gnome 3.22

Added by Steven Fosdick over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
09/30/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.6
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

On Gnome 3.22 darktable's appearance is somewhat odd. I attach a screenshot and a log from when darktable starts.

Library versions:

gtk3 3.22.0+29+gfa23641-1
gtkmm3 3.22.0-1
pango 1.40.3-1
pangomm 2.40.1-1
cairo-infinality-ultimate 1.14.6-2
cairomm 1.12.0-2
glib2 2.50.0+9+g34751ad-1

Not sure if this is also relevant but GDM with GNOME 3.22 changes the default display server from X11 to Wayland.

Screenshot from 2016-09-30 12-31-52.png (147 KB) Screenshot from 2016-09-30 12-31-52.png Steven Fosdick, 09/30/2016 02:32 PM
darktable.log (1.13 KB) darktable.log Steven Fosdick, 09/30/2016 02:32 PM
Screenshot from 2016-09-30 16-05-42.png (743 KB) Screenshot from 2016-09-30 16-05-42.png Peter Pro, 09/30/2016 05:07 PM

Related issues

Is duplicate of darktable - Bug #11185: Gtk 3.22 supportClosed: invalid09/29/2016

History

#1 Updated by Roman Lebedev over 3 years ago

  • Is duplicate of Bug #11185: Gtk 3.22 support added

#2 Updated by Roman Lebedev over 3 years ago

  • Status changed from New to Duplicate

#3 Updated by Roman Lebedev over 3 years ago

Steven Fosdick wrote:

Not sure if this is also relevant but GDM with GNOME 3.22 changes the default display server from X11 to Wayland.

Hm, so does darktable work on Wayland?
This is the first time i hear about it.
If so, good to know.

#4 Updated by Peter Pro over 3 years ago

Roman Lebedev wrote:

Steven Fosdick wrote:

Not sure if this is also relevant but GDM with GNOME 3.22 changes the default display server from X11 to Wayland.

Hm, so does darktable work on Wayland?
This is the first time i hear about it.
If so, good to know.

It works fine on Wayland. Even uses its own window decorations, I guess?

#5 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top