Project

General

Profile

Bug #11185

Gtk 3.22 support

Added by Peter Pro over 3 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
09/29/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.6
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Well, it certainly looks nice. Can't deny that.


Related issues

Has duplicate darktable - Bug #11188: Visual styling broken on Gnome 3.22Duplicate09/30/2016

Has duplicate darktable - Bug #11190: Red frames and too large menu fonts in lightroomDuplicate10/01/2016

Has duplicate darktable - Bug #11249: Display scaling on OS X b0rked in current masterDuplicate10/20/2016

History

#1 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Looks fine here.
Please try removing build directory (and clean install location), and rm custom css in ~/.config/darktable/*.css

#2 Updated by Peter Pro over 3 years ago

I did rebuild from source and now it looks fine indeed. Sorry, should have tried that first!

#3 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

#4 Updated by Roman Lebedev over 3 years ago

  • Has duplicate Bug #11188: Visual styling broken on Gnome 3.22 added

#5 Updated by Roman Lebedev over 3 years ago

  • Has duplicate Bug #11190: Red frames and too large menu fonts in lightroom added

#6 Updated by Steven Fosdick over 3 years ago

There was a message on the darktable-users mailing list to the effect this issue is fixed in 2.0.6 and yet it was with 2.0.6 I was seeing the problem (as the author of bug #11188 that is a duplicate of this one).

Building git master myself works fine.

Seeing comments about a vlean make me wonder if there is some conditional compilation going on - does darktable adapt to the version of gtk+ on the system is being built on?

#7 Updated by Steven Fosdick over 3 years ago

I didn't get long to try it much with Wayland as there is a much more serious issue with Gnome 3.22 on Wayland for me - if I use my KVM switch to switch the mouse to another PC and then switch back, as soon as I move the mouse gnome-shell crashes taking the whole session with it.

From what little I saw darktable seems fine on Wayland.

#8 Updated by Tobias Ellinghaus over 3 years ago

Steven Fosdick wrote:

does darktable adapt to the version of gtk+ on the system is being built on?

Yes, we ship several versions of the CSS file and install the one matching the used version of GTK. However, that check is done when CMake is run, so if GTK is updated later you have to clean build/ so the change is detected.

#9 Updated by Roman Lebedev over 3 years ago

  • Has duplicate Bug #11249: Display scaling on OS X b0rked in current master added

#10 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

#11 Updated by Gunnar Wegner over 3 years ago

I am also affected by this on Ubuntu 16.10 when I use the deb from darktable unstable ppa for 2.2.0rc0. Building from source solves the problem.

Also available in: Atom PDF

Go to top