Project

General

Profile

Feature #11183

DNG: ISO field reading

Added by Mathieu MD over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
09/27/2016
Due date:
% Done:

0%

Affected Version:
2.0.6
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When I import a NEF file from my Nikon D5500, it's recognized well, and the module "Noise reduction (profile)" find the right profile for the actual ISO number.
But when I convert this NEF to DNG (through DigiKam import module), then Darktable does not recognize it anymore: it can't find the white balance from the camera body, and the "Noise reduction" module only offers the "generic distribution" profile (which is quite damageful for images!).

I attached text files containing both files' Exif output from exiftool, and the two raw files themselves are here:

NEF_Exif.txt Magnifier (9.25 KB) Mathieu MD, 09/27/2016 11:25 PM

DNG_Exif.txt Magnifier (10.7 KB) Mathieu MD, 09/27/2016 11:25 PM


Related issues

Duplicates darktable - Bug #11108: Cameras.xml name "de-"mangling is broken, especially for nikon Fixed 08/10/2016

History

#1 Updated by Roman Lebedev over 2 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from NEF recognized, but not DNG to DNG: ISO field reading

Do keep in mind that converting to DNG is lossy process, and such issues not only should be unsurprised, but to be expected.

#2 Updated by Mathieu MD over 2 years ago

I believed DNG conversion was supposed to be possible lossless (for the picture itself, at least), is it not the case? https://en.wikipedia.org/wiki/Digital_Negative

Anyway, from now on, I get back to use NEF instead, indeed.

#3 Updated by Roman Lebedev over 2 years ago

Mathieu MD wrote:

I believed DNG conversion was supposed to be possible lossless (for the picture itself, at least), is it not the case? https://en.wikipedia.org/wiki/Digital_Negative

supposed. it is absolutely not lossless, metadata can and most likely will be lost. it all depends on the software.

Anyway, from now on, I get back to use NEF instead, indeed.

There is absolutely no reason at all to convert to DNG from other raw format; but on the other hand if camera can natively produce DNG, it may be best to use DNG.

#4 Updated by Mathieu MD over 2 years ago

supposed. it is absolutely not lossless, metadata can and most likely will be lost. it all depends on the software.

Do you mean I should open a bug at DigiKam too?

There is absolutely no reason at all to convert to DNG from other raw format;

Even regarding the openness of DNG (which should make of it a good format for archival purposes), versus the closeness of proprietary raw file formats?

but on the other hand if camera can natively produce DNG, it may be best to use DNG.

I'm afraid Nikon (or Canon) is not going to support DNG anytime soon...

Thanks for your comments.

#5 Updated by Roman Lebedev over 2 years ago

Mathieu MD wrote:

supposed. it is absolutely not lossless, metadata can and most likely will be lost. it all depends on the software.

Do you mean I should open a bug at DigiKam too?

Wait, that DNG is not even from adobe dng converter, but from something else?

There is absolutely no reason at all to convert to DNG from other raw format;

Even regarding the openness of DNG (which should make of it a good format for archival purposes), versus the closeness of proprietary raw file formats?

Yes, absolutely.
Once one version of some software can open specific proprietary raw file format, that version can be used do to so (not counting various dependency and other problems)

but on the other hand if camera can natively produce DNG, it may be best to use DNG.

I'm afraid Nikon (or Canon) is not going to support DNG anytime soon...

True :(

Thanks for your comments.

#6 Updated by Mathieu MD over 2 years ago

Do you mean I should open a bug at DigiKam too?

Wait, that DNG is not even from adobe dng converter, but from something else?

You mean this?
https://helpx.adobe.com/photoshop/using/adobe-dng-converter.html

How could I? There is no GNU/Linux version, and -- more importantly -- it's not FLOSS!

Once one version of some software can open specific proprietary raw file format, that version can be used do to so (not counting various dependency and other problems)

Yes, you're right (although it's right only for open source softwares)

#7 Updated by Tobias Ellinghaus over 2 years ago

Mathieu MD wrote:

Even regarding the openness of DNG (which should make of it a good format for archival purposes), versus the closeness of proprietary raw file formats?

The problem isn't with the DNG themselves. As Roman said, if a camera can write them natively it's the preferred format. However, in order to convert other raw files to DNG the software doing so has to understand the original RAW file to a degree that I doubt many will do. There are so many undocumented bits of information in the Exif maker notes which are only discovered eventually that converted files are most likely missing.

#8 Updated by Roman Lebedev over 2 years ago

Can not reproduce, for me in darktable both images have iso = 640.
The actual problem is camera name mangling for dng :(

#9 Updated by Roman Lebedev over 2 years ago

  • Duplicates Bug #11108: Cameras.xml name "de-"mangling is broken, especially for nikon added

#10 Updated by Roman Lebedev over 2 years ago

  • Status changed from New to Duplicate

#11 Updated by Roman Lebedev over 2 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF