Project

General

Profile

Camera Support #11178

darktable 2.0.6 reporting a segfault on import from camera

Added by Phil Wright about 3 years ago. Updated over 2 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
09/27/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch

Description

Darktable crashes while importing images from my Nikon D90.

OS: Xubuntu 16.04.1

linux terminal output running 'darktable':

darktable
[defaults] found a 64-bit system with 32858108 kb ram and 8 cores (0 atom based)
[defaults] setting high quality defaults
[New LWP 6690]
[New LWP 6691]
[New LWP 6692]
[New LWP 6693]
[New LWP 6694]
[New LWP 6695]
[New LWP 6696]
[New LWP 6697]
[New LWP 6698]
[New LWP 6699]
[New LWP 6700]
[New LWP 6701]
[New LWP 6702]
[New LWP 6703]
[New LWP 6704]
[New LWP 6705]
[New LWP 6706]
[New LWP 6707]
[New LWP 6708]
[New LWP 6709]
[New LWP 6710]
[New LWP 6711]
[New LWP 6712]
[New LWP 6713]
[New LWP 6714]
[New LWP 6715]
[New LWP 6716]
[New LWP 6722]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007fb51fe61fbb in __waitpid (pid=6734, stat_loc=0x0, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:29
29    ../sysdeps/unix/sysv/linux/waitpid.c: No such file or directory.
backtrace written to /tmp/darktable_bt_NU78NY.txt
Segmentation fault (core dumped)

darktable_bt_NU78NY.txt (47.4 KB) darktable_bt_NU78NY.txt crash dump Phil Wright, 09/27/2016 08:25 AM
lshw.txt (21.3 KB) lshw.txt lshw output Phil Wright, 09/27/2016 08:26 AM

History

#1 Updated by Roman Lebedev about 3 years ago

Wrong tracker!

Yeah, that has been there for a while.
Not sure whether this is dt bug, or yet another gtk issue.

#2 Updated by Phil Wright about 3 years ago

Strange workaround?

I decided to try running darktable via strace

strace -t -o darktable_strace_$(date +"%F_%H-%M-%S").log darktable

to see if I could spot any clues to the crash, but every time I do darktable works perfectly.

Every time I run darktable without strace, it crashes.

I've now made a simple shell script to launch darktable via strace. The problem isn't solved, but at least I can use darktable.

#3 Updated by Roman Lebedev about 3 years ago

From my observations, it crashes the second time import dialog opened.
Any import dialog counts, be it single file or directory.
Also, as i said, wrong tracker.

#4 Updated by Tobias Ellinghaus about 3 years ago

  • Affected Version set to git master branch
  • Project changed from website to darktable
  • Tracker changed from Bug to Camera Support

#5 Updated by Phil Wright about 3 years ago

Roman Lebedev wrote:

Also, as i said, wrong tracker.

I have no idea what that means. I was searching around for darktable support, found the bug reporting page, and posted a bug report. I didn't see anything about 'trackers', whatever they are.

Roman Lebedev wrote:

From my observations, it crashes the second time import dialog opened.

In my case it's the first time the import dialog is opened, every time, and only when the import process is nearly complete.

Also, I don't see how it has anything to do with the camera model. The same camera has always worked without any problem on previous versions of darktable on Xubuntu 14.04.

Anyway, darktable runs fine when launched via strace so at least I can continue working.

#6 Updated by Stefan Schöfegger over 2 years ago

Does these issue exist with current darktable version anymore?

#7 Updated by Richard Wonka over 2 years ago

Can confirm that current dt crashes reliably on the second import - sometimes on the first.

I get the feeling that this might be a race condition. When I start dt and leave it alone for a while, on a not-super fast dual core i5 machine with 8GB RAM and 512BG SSD, dt seems to be less likely to crash.

the strace workaround would support this theory, but not prove it...

Also available in: Atom PDF

Go to top