Project

General

Profile

Bug #11158

dt crash badly when working interactively

Added by Pascal Obry almost 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Critical
Assignee:
Category:
Darkroom
Target version:
Start date:
09/17/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

This happens only when OpenCL is activated and it happens only when doing interactive changes.

That is selecting a bunch of images and doing an export works fine.

To reproduce:
- have OpenCL activated (I'm on NVIDIA)
- open the base curve or the tone curve, try moving the curve
=> it crashes almost instantly

This is a recent regression. I have bisected this to:

commit a18488567cd2a1072f8516518eba0f1b5f612351
Author: Roman Lebedev <lebedev.ri@gmail.com>
Date:   Wed Aug 31 21:12:37 2016 +0300

    IOPs, pipe: replace output_bpp() with output_format()

    If output_bpp() is the same as default-one - drop it

The backtrace I have on GDB does not seems very instructive.

Thread 11 "darktable" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffbadd1700 (LWP 3928)]
0x00007fffd8ace6dc in ?? ()
   from /usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1
(gdb) bt
#0  0x00007fffd8ace6dc in ?? ()
   from /usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1
#1  0x00007fffd8b714fe in ?? ()
   from /usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1
#2  0x00007fffd8c64edf in ?? ()
   from /usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1
#3  0x00007fffd8b95423 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1
#4  0x00007fffd8906ba4 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1
#5  0x00007fffd8c19e88 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1
#6  0x00007fffd8b8d138 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1
#7  0x00007ffff352d464 in start_thread (arg=0x7fffbadd1700)
    at pthread_create.c:333
#8  0x00007fffefacc97f in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Related issues

Is duplicate of darktable - Bug #11149: Possible opencl regressionFixed09/12/2016

History

#1 Updated by Roman Lebedev almost 4 years ago

  • Is duplicate of Bug #11149: Possible opencl regression added

#2 Updated by Roman Lebedev almost 4 years ago

  • Status changed from New to Duplicate

#3 Updated by Pascal Obry almost 4 years ago

Indeed a duplicate :( sorry for the noise I should have been looking harder!

#4 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top