Project

General

Profile

Bug #11114

Equalizer module does not keep adjustment values between launches

Added by Nick Kachulin over 3 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
08/16/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.5
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When I use Clarity preset and e.g. low down the strength, darktable looses it on exit. The module stays on but does nothing (flat 1:1 value, doesn't change the pic when module toggled on/off). When I apply a preset once more, it works ok until exit. The same with style containing the Clarity setup -- it is there but not functional when applied to another image.
The git version I tried behaves the same way.


Related issues

Is duplicate of darktable - Feature #8601: Equalizer mix setting not persistingClosed: won't fix

History

#1 Updated by Roman Lebedev over 3 years ago

  • Is duplicate of Feature #8601: Equalizer mix setting not persisting added

#2 Updated by Roman Lebedev over 3 years ago

  • Status changed from New to Duplicate

#3 Updated by Nick Kachulin over 3 years ago

Roman, it is obviously a bug and not a duplicate of #8601. I double-checked it once more.

#8601 says "But for me the result (so the values set in the eq histogram) stay the tuned one." Yes, it behaves this way until I close the application. Having opened dt again, the tuning is LOST. Toggling the module on/off changes NOTHING in the image -- and I have stated this when opened the ticket.
Please don't close the tickets without checking them out (or, at least, reading them carefully).
Anyway, thanks for the great app!

#4 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 0 to 20
  • Status changed from Duplicate to Incomplete

Which distro is this?

low down the strength
the tuning is LOST

Are you talking about "mix" slider here?

https://www.darktable.org/usermanual/ch03s04s04.html.php#equalizer

This module additionally has a “mix” slider below the spline GUI.
Adjusting the slider will upscale or downscale the splines on the y-axis.
The slider was added as a convenience tool to help you modify the strength of the effect.
It is not a module parameter in itself; when you leave darkroom mode all changes will be consolidated into the spline curves.

#5 Updated by Nick Kachulin over 3 years ago

Yes, I'm talking about the "mix" slider.
However, I've build the git version in a meantime and it looks like the issue has gone: I can not reproduce it anymore. I had to re-save some previously stored styles that used the eq and now it works as supposed: it shows 1.000 as a "mix" value but the image changes when eq on/off -- which is completely fine with me. The value is kept correctly, too -- I've checked this.

So, for me using the git version is just fine -- I cannot see any issues on it this far.

You probably may close the ticket, and I'll let you know if I experience this behavior again.
Thanks a lot for your time. Actually this was a very annoying bug for me -- I had to re-apply the eq module every time I needed to export photos (and I sometimes forgot about it -- resulting in softer images exported/printed).

#6 Updated by Tobias Ellinghaus over 3 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

One thing that comes to mind is that the eq module's effect depends on the image size. So zooming in darkroom changes the look, and also export size when not using HQ exports. Maybe that's an explanation?

I am setting this to "invalid" for the time being as we don't know what caused the bug. If you encounter it again we can just reopen.

#7 Updated by Nick Kachulin over 3 years ago

I don't think it's the case.
To me it looks much like some environmental issue. I don't know if that thing is possible, but what comes to my mind is some garbage in the database or conf file or any other surplus that went into the way. Some leftover after a crash or something. fglrx I use crashes X11 sometimes -- that might be the reason (keep dreaming about open source opencl. darktable is the only reason I keep the blob).
Anyway, thank you guys for your efforts! You've created a really great piece of software!

#8 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top