Project

General

Profile

Bug #11111

Print Tab with no functionality

Added by Peter Harde over 3 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Printing
Target version:
Start date:
08/13/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.5
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

- select an image in ligthtable
- select tab print
- no preview of image on sheet is shown
- printer section as shown in attached image :
- no printer shown
- combobox for "paper format" does not open when clicked
- clicking on "Print" button does nothing

further information :
- operationg system : Ubuntu 16.04.1 LTS (Linux 4.4.0-34)
- cups shows 1 printer (Brother DCP-382C) which is working fine
- gnome dialogs show 3 printers : PDF, Brother DCP-385C, both working fine. Additionally "print", which seens to be an issue of brother printers in the latest ubuntu versions. This third printer entry in the gnome dialog can not be used, it rejects every job. Existance of "print" causes no problems in other applications.

DSC00311-darktable-print.jpg (217 KB) DSC00311-darktable-print.jpg printer section of print tab Peter Harde, 08/13/2016 12:40 PM

History

#1 Updated by Peter Harde over 3 years ago

Today cups has been updated via the ubuntu 16.04 repositories. After this update the Print Tab of darktable is working as expected. cups (not darktable) appears to be the reason for the issue reported above. Otherwise : in the Print Tab only the printer known by cups (Brother DCP-385C) is shown, the pdf-printing option of the gnome dialogs is not available.

#2 Updated by Roman Lebedev over 3 years ago

  • Status changed from New to Closed: invalid

Peter Harde wrote:

Today cups has been updated via the ubuntu 16.04 repositories. After this update the Print Tab of darktable is working as expected. cups (not darktable) appears to be the reason for the issue reported above.

Good, i'll close this then.

Otherwise : in the Print Tab only the printer known by cups (Brother DCP-385C) is shown, the pdf-printing option of the gnome dialogs is not available.

Print tab only operates with cups directly, so unless you do not see the printer in cups settings, dt will not see it either.

#3 Updated by Peter Harde over 3 years ago

The issue is back again. My guess that cups was the reason for the behavior described, was obviously wrong. Neither cups nor darktable nor the printer connected have been modified in any manner. When opening the "Print Tab" only a completely white sheet is schown on dark background, printer section without any printer. cups definitely knows the Brother DCP-385C. Currently the behavior is a mystery for me.

#4 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top