Project

General

Profile

Bug #11103

I can't change camera and lens

Added by Marek Potocki over 3 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
07/31/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
openSUSE
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi, I don't know where is source of problem, but I can't change lens. When i open lens correction dialog, camera list is empty, and all switches are inactive.

dialog.png (13.9 KB) dialog.png Marek Potocki, 07/31/2016 08:30 AM
photo_info.png (25.3 KB) photo_info.png photo info Marek Potocki, 07/31/2016 11:50 AM
DC.png (426 KB) DC.png Image with antoher lens settings. Marek Potocki, 07/31/2016 12:33 PM
II DC.png (445 KB) II DC.png Image with automatic detected lens. Marek Potocki, 07/31/2016 12:33 PM

History

#1 Updated by Roman Lebedev over 3 years ago

Please also show the "image information" lib (in left sidepanel)

#2 Updated by Marek Potocki over 3 years ago

There is image info.

#3 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Hm, and which lensfun versions are installed?
Also, what does grep "40D" /usr/share/lensfun/version_1/slr-canon.xml (<- filepath may differ) says?

#4 Updated by Marek Potocki over 3 years ago

Roman Lebedev wrote:

Hm, and which lensfun versions are installed?

liblensfun0 0.3.1-16.1
liblensfun1 0.3.2-18.2
lensfun-data 0.3.2-18.2

But after downgrade lensfun-data to 0.3.1 it works.

Thanks :)

But why I need to change lens?
Default settings for my "Sigma 18-200mm f/3.5-6.3 II DC OS HSM" gives wrong effect (chromatic aberration). Correct image I receive with "Sigma 18-200mm f/3.5-6.3 DC".

#5 Updated by Roman Lebedev over 3 years ago

Marek Potocki wrote:

Roman Lebedev wrote:

Hm, and which lensfun versions are installed?

liblensfun0 0.3.1-16.1
liblensfun1 0.3.2-18.2
lensfun-data 0.3.2-18.2

But after downgrade lensfun-data to 0.3.1 it works.

Yeah, they all be of the same version

Thanks :)

But why I need to change lens?
Default settings for my "Sigma 18-200mm f/3.5-6.3 II DC OS HSM" gives wrong effect (chromatic aberration). Correct image I receive with "Sigma 18-200mm f/3.5-6.3 DC".

I do not see which of those lens is displayed in image information, but you have one lens, and it wrongly corrects it, sounds like a calibration issue, please report that to lensfun

#6 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

Closing as lensfun issue

#7 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top