Project

General

Profile

Bug #10994

Thumbnails in lighttable not sharp/badly rendered

Added by Wiebke Jahr almost 4 years ago. Updated 8 months ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
04/14/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0.3
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

This problem started to occur with version 2.0.0, but might have gotten worse (not sure anymore).
Thumbnails in lighttable are not displayed as crisp as in darkroom. I suspected bug #10731, but changing the screen_ppd_overwrite values effects mostly the appearance in darkroom, not in lighttable (see attached images ... darkroom05 is a screenshot with the screen_ppd_overwrite set tu 0.5, darkroom10 with the value set to 1.0 etc.).

Different from bug #10731, the appearance in lighttable is not only not sharp, but seems also of much lower resolution. The problem gets worse after developing an image, especially after cropping. I'm also attaching my darktablerc file, maybe there's just some setting messed up.

Screen cofiguration: Lenovo T61 1440x900 with attached external LG 1920x1080. I usually open darktable on the external screen, but the problem is seen on both.

darktablerc (20.5 KB) darktablerc Wiebke Jahr, 04/14/2016 11:27 PM
darkroom05.png (1.85 MB) darkroom05.png Wiebke Jahr, 04/14/2016 11:28 PM
darkroom10.png (2.22 MB) darkroom10.png Wiebke Jahr, 04/14/2016 11:28 PM
lighttable05.png (1.32 MB) lighttable05.png Wiebke Jahr, 04/14/2016 11:28 PM
darkroom20.png (2.2 MB) darkroom20.png Wiebke Jahr, 04/14/2016 11:28 PM
lighttable10.png (1.34 MB) lighttable10.png Wiebke Jahr, 04/14/2016 11:28 PM
lighttable20.png (1.36 MB) lighttable20.png Wiebke Jahr, 04/14/2016 11:29 PM
05lighttable.png (752 KB) 05lighttable.png Wiebke Jahr, 05/08/2016 01:44 PM

Related issues

Related to darktable - Bug #10731: Thumbnails are not sharp in lighttableFixed11/19/2015

History

#1 Updated by Roman Lebedev almost 4 years ago

  • Related to Bug #10731: Thumbnails are not sharp in lighttable added

#2 Updated by Wiebke Jahr almost 4 years ago

It's still there in version 2.04, and I honestly think is not related to bug #10731. It arises only after I touched the image in darkroom.

I attached a couple more screenshots to illustrate the behaviour. When I first open the image in lighttable, it's crisp (01lighttable). When I go to darkroom (02darkroom) and back to lighttable (03lighttable), it's still crisp (interestingly, the color changes). I go back to darkroom and crop (04darkroom). Back in lighttable (05lighttable), it is now fuzzy. When I discard the whole history stack, the image is immediately sharp again (06lighttable).

The same behaviour occurs when I adjust contrast, change the levels ... Also, when I delete the history stack from darkroom (clicking on "0 original" and then on "compress history stack"), I get a sharp image again in light table.

#3 Updated by Wiebke Jahr almost 4 years ago

There's some problems with uploading the files, I'm hosting them here for the time being:
https://cloudstore.zih.tu-dresden.de/public.php?service=files&t=0a8e1ee6841e379842886b00e1abf160

#4 Updated by Johannes Hanika almost 4 years ago

Wiebke Jahr wrote:

There's some problems with uploading the files, I'm hosting them here for the time being:
https://cloudstore.zih.tu-dresden.de/public.php?service=files&t=0a8e1ee6841e379842886b00e1abf160

please try replacing

plugins/lighttable/low_quality_thumbnails=TRUE

with

plugins/lighttable/low_quality_thumbnails=FALSE

i your darktablerc.

#5 Updated by Roman Lebedev almost 4 years ago

Start by inverting the following options in darktablerc:

never_use_embedded_thumb=FALSE (set to TRUE)
plugins/lighttable/low_quality_thumbnails=TRUE (set to FALSE)
plugins/lighttable/export/high_quality_processing=FALSE (set to TRUE)

#6 Updated by Wiebke Jahr almost 4 years ago

Thanks Johannes and Roman,
changing plugins/lighttable/low_quality_thumbnails=TRUE
to plugins/lighttable/low_quality_thumbnails=FALSE
solves the problem.
It seems to slow down darktable a bit, but then my hardware is also (a tiny little bit) outdated.

Changing
never_use_embedded_thumb=FALSE (set to TRUE) or
plugins/lighttable/export/high_quality_processing=FALSE (set to TRUE)
does not work.

I don't think I have permission to close bug reports, but I consider this solved.

#7 Updated by Roman Lebedev almost 4 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Fixed

Wiebke Jahr wrote:

Thanks Johannes and Roman,
changing plugins/lighttable/low_quality_thumbnails=TRUE
to plugins/lighttable/low_quality_thumbnails=FALSE
solves the problem.

Good to hear that.

It seems to slow down darktable a bit, but then my hardware is also (a tiny little bit) outdated.

Yes, that is expected, and that is why it was not on (in your case) by default.

Changing
never_use_embedded_thumb=FALSE (set to TRUE) or

That should fix what you have stated in https://redmine.darktable.org/issues/10994#note-2 about colors

plugins/lighttable/export/high_quality_processing=FALSE (set to TRUE)
does not work.

That one is only for export, not thumbs, so that is normal.

I don't think I have permission to close bug reports, but I consider this solved.

#8 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

#9 Updated by William Macdougall 8 months ago

Bug is basically the error which prevails in the file and the whole system due to the present of the form of error with the recognition. The issue of the dart table is for https://www.britishessayhq.com/5-5-10-myassignmenthelp-com-review/ in which the badly rendered has the name of the issue and the sense of the report.

Also available in: Atom PDF

Go to top