Project

General

Profile

Bug #10993

GNOME 3.20 breaks git build (deprecated features)

Added by Tuan Kiet Ho almost 4 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Buildsystem
Target version:
Start date:
04/12/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

As GNOME 3.20 has been released, builds are broken as there're some source files that contains deprecated GDK declarations:

  • src/bauhaus/bauhaus.c
  • src/control/control.c
  • src/gui/gtk.c
  • src/libs/tools/ratings.c
  • src/libs/tools/filmstrip.c
  • src/libs/histogram.c
  • src/libs/navigation.c
  • src/iop/lowlight.c
  • src/iop/atrous.c
  • src/iop/monochrome.c
  • src/iop/levels.c

Normally this will only raise deprecated declarations warnings, but Darktable's build system treats all warnings as errors, so this prevents the build process.

Attached is the build log, which contains the build log after I added -Wno-error=deprecated-declarations to CMAKE_C_FLAGS (so that you know where to fix)

build.log (90 KB) build.log Tuan Kiet Ho, 04/12/2016 06:13 PM

Related issues

Is duplicate of darktable - Bug #10976: GTK 3.20 ThemeFixed04/03/2016

History

#1 Updated by Tuan Kiet Ho almost 4 years ago

Attached the build log.

#2 Updated by Roman Lebedev almost 4 years ago

  • Is duplicate of Bug #10976: GTK 3.20 Theme added

#3 Updated by Roman Lebedev almost 4 years ago

  • Status changed from New to Duplicate

#4 Updated by Tuan Kiet Ho almost 4 years ago

Actually I first considered adding a comment to #10976 but since this was about the build system, not the theme so I decided to make a new ticket instead.

#5 Updated by Roman Lebedev about 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top