Project

General

Profile

Bug #10990

Button/icon sizes too large with GTK 3.20

Added by Owen Mays about 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
04/10/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.3
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

This behavior is present in 2.0.3 and in the most recent git master (d6a0066bfd22e621eab4f82ec0958d3a930ff052). Following upgrade to GTK 3.2, button sizes and some text are too large (see attached screenshot). The contents of module boxes doesn't fit right as a result.

Launching darktable generates the following warnings:
@
(darktable:8004): Gtk-WARNING **: Theme parsing error: darktable.css:30:26: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(darktable:8004): Gtk-WARNING **: Theme parsing error: darktable.css:200:28: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(darktable:8004): Gtk-WARNING **: Theme parsing error: darktable.css:365:50: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(darktable:8004): Gtk-WARNING **: Theme parsing error: darktable.css:366:37: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(darktable:8004): Gtk-WARNING **: Theme parsing error: darktable.css:436:30: The style property GtkWidget:wide-separators is deprecated and shouldn't be used anymore. It will be removed in a future version

(darktable:8004): Gtk-WARNING **: Theme parsing error: darktable.css:437:30: The style property GtkWidget:separator-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(darktable:8004): Gtk-WARNING **: Theme parsing error: darktable.css:438:31: The style property GtkWidget:separator-height is deprecated and shouldn't be used anymore. It will be removed in a future version
@

2016-04-10-123325_1918x1061_scrot.png (124 KB) 2016-04-10-123325_1918x1061_scrot.png Screenshot showing the large interface Owen Mays, 04/10/2016 08:38 PM

Related issues

Is duplicate of darktable - Bug #10976: GTK 3.20 ThemeFixed04/03/2016

Has duplicate darktable - Bug #11249: Display scaling on OS X b0rked in current masterDuplicate10/20/2016

History

#1 Updated by Roman Lebedev about 4 years ago

  • Status changed from New to Duplicate
  • Subject changed from Button/icon sizes too large with GTK 3.2 to Button/icon sizes too large with GTK 3.20

#2 Updated by Roman Lebedev about 4 years ago

  • Is duplicate of Bug #10976: GTK 3.20 Theme added

#3 Updated by Roman Lebedev over 3 years ago

  • Has duplicate Bug #11249: Display scaling on OS X b0rked in current master added

#4 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top