Project

General

Profile

Bug #10979

Fullscreen mode editing glitches when activating OpenCL, Ubuntu 15.10

Added by Cyrille Lauzon about 4 years ago. Updated about 4 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
-
Start date:
04/03/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.3
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When activating OpenCL using the Nvidia Driver in fullscreen mode only, the screen randomly flashes when refreshing the screen. It happens when moving any slider to edit in Darkroom. Deactivating OpenCL or going out of fullscreen corrects the bug.


Related issues

Related to darktable - Bug #10876: import camera tooltip flickersClosed: upstream01/15/2016

Related to darktable - Bug #10786: Visual glitch when moving slidersClosed: upstream12/16/2015

History

#1 Updated by Roman Lebedev about 4 years ago

Sounds like something related to tearing.
Also, i think it might be not darktable but upstream issue.

#2 Updated by Cyrille Lauzon about 4 years ago

Correction and details: It does happen as well without OpenCl activated but strictly in fullscreen mode. As if the content of another window is appearing very rapidly. Just a pop once in a while, when moving a slider window, or selecting a develop module in another tab. My config is vanilla ubuntu gnome 15.10 with the nvidia display driver. If worth mentionning, I did install fedora 23 with the nvidia driver and was having the same issue. Thanks.

#3 Updated by Roman Lebedev about 4 years ago

  • Related to Bug #10876: import camera tooltip flickers added

#4 Updated by Roman Lebedev about 4 years ago

  • Related to Bug #10786: Visual glitch when moving sliders added

#5 Updated by Van de Bugger about 4 years ago

Fedora 23 x86_64, Gnome 3 with Gnome shell, nvidia driver, darktable 2.0.4.

I confirm the bug. OpenCL does not matter, darktable glitches in fullscreen mode with and without --disable-opencl option.

I have glitch when any drop-down box disappears. For example: darktable view -> open and rotate -> guides -> select any guide type -> glitch!

However, the problem is not persistent. I tried to investigate conditions (if it depends on other windows, etc) and moved few windows to another workspace… and darktable stopped glitching. Moving that windows back to original workspace did not restore the problem. :-(

Also available in: Atom PDF

Go to top