Project

General

Profile

Bug #10963

issue with mask and crop&rotate

Added by Pascal Obry about 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Medium
Category:
-
Target version:
Start date:
03/26/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

There is a small discrepancy between the mask and the effect when crop&rotate is activated with a rotation (even a small of 1°).

To reproduce:

- open a picture (portrait mode seems to have the effect a bit more visible)
- use exposure module, create a drawn mask (curve seems to be more visible, but a circle works fine too)
- use no feather to have the effect more visible (the dotted line should be as close as possible to the mask area)
- open crop&rotate, use a 1° rotation.
- select back the exposure module, display the drawn masks and the mask itself (yellow area)

=> the outline of the mask and the area itself does not really match, there is a small offset.


Related issues

Is duplicate of darktable - Bug #10928: Spot removal tool has an offset at targetFixed02/21/2016

History

#1 Updated by Aldric Renaudin about 4 years ago

  • Status changed from New to Duplicate

#2 Updated by Roman Lebedev about 4 years ago

  • Is duplicate of Bug #10928: Spot removal tool has an offset at target added

#3 Updated by Pascal Obry about 4 years ago

And the PR#1161 does fix this issue! So we should probably merge it.

#4 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top