Project

General

Profile

Bug #10957

red artifacts appear if colorcurve and equalizer are enabled in combination

Added by Toni Burger almost 4 years ago. Updated over 3 years ago.

Status:
Fixed: To be cherry-picked
Priority:
Low
Category:
Darkroom
Target version:
Start date:
03/19/2016
Due date:
% Done:

90%

Estimated time:
Affected Version:
2.0.2
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

using the ToneCurve-Module in combination with the Equalizer-Module (to sharpen details) leads to red artifacts in the Picture.

The problem only occurs, if openCl is enabled.

I attached a sample Raw File and the corresponding xmp file.

DSC_6870.NEF.xmp (9.23 KB) DSC_6870.NEF.xmp Toni Burger, 03/19/2016 09:49 PM
screenDarktable.png (824 KB) screenDarktable.png screenshot Toni Burger, 03/19/2016 09:57 PM
DSC_6870.NEF (25.8 MB) DSC_6870.NEF Toni Burger, 03/19/2016 10:00 PM

Associated revisions

Revision 8de505ce (diff)
Added by Ulrich Pegelow almost 4 years ago

tonecurve: fix long standing bug in opencl codepath; fixes #10957

Revision 0c907a02 (diff)
Added by Ulrich Pegelow almost 4 years ago

tonecurve: fix long standing bug in opencl codepath; fixes #10957

(cherry picked from commit 8de505ce8b41251442704b9567f73db9fb7703ce)

History

#1 Updated by Ulrich Pegelow almost 4 years ago

  • % Done changed from 0 to 10
  • Assignee set to Ulrich Pegelow
  • Status changed from New to Confirmed

Seems to be a problem in the tonecurve module.

#2 Updated by Ulrich Pegelow almost 4 years ago

  • % Done changed from 10 to 90
  • Status changed from Confirmed to Fixed: To be cherry-picked

It's fixed in commit 8de505ce8b41251442704b9567f73db9fb7703ce and should be cherry-picked into the 2.0.x branch.

#3 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top