Project

General

Profile

Bug #10915

Black or white squares on exported images

Added by hxy io over 2 years ago. Updated over 2 years ago.

Status:
Incomplete
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
02/13/2016
Due date:
% Done:

20%

Affected Version:
git development version
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Darktable is exporting my images with black or white squares on them.

Here's my workflow:

1. Import raw .DNG files from Ricoh GR II into Darktable

2. Work on said files, applying various tweaks

3. Export images to disk with the following settings:

  • Target storage: File on disk
  • File format: JPEG (8-bit)
  • Quality: 100%
  • Max size: 2000 x 2000
  • Allow upscaling: no
  • Profile: image settings
  • Intent: image settings
  • Style: none

Attached is an example raw .DNG, the .xmp sidecar file and the exported .jpg,
the white square is just to our right of the dog's collar.

Each time I export my images, these squares are in a different place on the
jpeg. Some images have white squares, some images have black squares and some
images seem to be free from these squares entirely.

I'm running Darktable on Arch Linux, installed from the official Arch Linux
community repo (version 2.1.0-2).

Below is the output of `darktable --version`:

this is darktable 2.1.0
copyright (c) 2009-2015 johannes hanika
compile options:
OpenMP support enabled
OpenCL support enabled
Lua support enabled
Colord support enabled
gPhoto2 support enabled
GraphicsMagick support enabled

Please let me know if there's anything else I can provide to be of more
assistance.

Thanks!

PS. 2.1.0 is not an available option in the "Affected Version" list of
the "New issue" form, so I've had to select something else.

R0000309.DNG.xmp (11 KB) hxy io, 02/13/2016 07:12 PM

20160131114412.jpg (1.28 MB) hxy io, 02/13/2016 07:12 PM

R0000309.DNG (17.9 MB) hxy io, 02/13/2016 07:14 PM

R0000884.DNG.xmp (6.06 KB) hxy io, 05/15/2016 11:44 AM


Related issues

Related to darktable - Bug #10777: Fuji JPG is read with black artefacts Fixed 12/12/2015

History

#1 Updated by Roman Lebedev over 2 years ago

  • Affected Version changed from git stable branch to git development version

2.1.0 is not a version, it is git development version, git master.

#2 Updated by Roman Lebedev over 2 years ago

  • Related to Bug #10777: Fuji JPG is read with black artefacts added

#3 Updated by Roman Lebedev over 2 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Please try with proper 2.0.1 release.

#4 Updated by Tobias Ellinghaus over 2 years ago

Actually, 2.1.0 is basically 2.0.0.

#5 Updated by hxy io over 2 years ago

Roman Lebedev wrote:

Please try with proper 2.0.1 release.

I'm still experiencing this issue with the 2.0.4 version of
Darktable:

this is darktable 2.0.4
copyright (c) 2009-2015 johannes hanika
compile options:
normal build
OpenMP support enabled
OpenCL support enabled
Lua support enabled, API version 3.0.0
Colord support enabled
gPhoto2 support enabled
GraphicsMagick support enabled

Attached is another example raw .DNG, the .xmp sidecar file and the
exported .jpg. There are two black squares are above the bike and
another in the bottom left of the image.

I could be wrong, but I think the artifacts start to appear only after
the lens correction module is enabled.

Please let me know if there's anything else I can do or provide to help!

Files couldn't be attached to this message, so I have made them
temporarily available these URLs:

Thanks

#6 Updated by hxy io over 2 years ago

I have discovered these artefacts do not appear with OpenCL support disabled.

Also available in: Atom PDF