Project

General

Profile

Bug #10908

Opacity slider doesn't show adjustment by key combo + mouse wheel

Added by Mark Garrow over 4 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Category:
Masks
Target version:
Start date:
02/08/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.1
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Ubuntu 14.04 64bit
DT 2.0.1 from Pascal's PPA

I recently discovered changing the opacity of a drawn mask using the Ctrl+mouse wheel combo. Using this method to change the opacity does not move the opacity slider at all in the module of choice.

The expected behavior would be to move the opacity slider by the same amount that is applied using the key+mouse combo. Currently they work independently of each other.

If the opacity slider is used to reduce opacity, ctrl+mouse wheel will not bring it back to 100% and vice verse. Since they are controlling the same thing, they should be tied together where adjustment using one method can be readjusted or changed by the other method.

I suspect this behavior is what has frustrated me for the last several days trying to figure out why a drawn mask was not being applied 100% despite the opacity slider showing 100%. After renaming darktablerc my system when back to normal and everything worked. A reply to my G+ post by Matthieu Moy gave me the clue to the ctrl+mouse wheel combo as the likely culprit to my confusion.

History

#1 Updated by Aldric Renaudin over 4 years ago

  • Status changed from New to Closed: invalid

Yes, there is 2 different opacity : one is global for all the iop, the second one is related to the drawn mask opacity.
They don't have to be tied together, as you can set opacity individually for the masks (you can have form1 at 100% and form2 at 50%)
btw, drawn mask opacity are shown in the mask manager in the left panel.

#2 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top