Project

General

Profile

Bug #10898

Unable to load Sony Xperia Z3/Z3c JPG

Added by Licaon Kter about 4 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
01/29/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.0
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Unsupported color conversion request
[rawspeed] No decoder found. Sorry.
allocation failed???
DSC_0077.JPG (3.5 MB) DSC_0077.JPG Licaon Kter, 01/29/2016 06:01 PM

History

#1 Updated by Pedro Côrte-Real about 4 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

That file works fine here so this is probably something wrong in your install. By the error message it's probably something in libjpg that's broken. Do other programs on your system support that image?

#2 Updated by Licaon Kter about 4 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

Yes, found the culprit, was using the unstable PPA, so in Ubuntu it links to libosmgpsmap-1.0-0 and libgraphicsmagick3, and I had those, but in Debian Sid it's up to libosmgpsmap-1.0-1 and libgraphicsmagick-q16-3 1.3.23-1.

Switching to the Debian provided darktable + dependency package(s) fixes it, so it's either lose the ability to test unstable builds as published on the PPA (go back to building it myself again) or lose the ability to open JPGs.

/PS: yes yes I know, "DO NOT INSTALL THESE BINARY PACKAGES IN DEBIAN." yet they were working so fine for years :(.

#3 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top