Project

General

Profile

Bug #10892

Pick color tool in modules parametric blending interface does not work

Added by Serge Gavrilov over 4 years ago. Updated over 2 years ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
-
Start date:
01/26/2016
Due date:
% Done:

10%

Estimated time:
Affected Version:
2.0.0
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi!

It seems that pick color tool in modules parametric blending interface does not work. At least the position of the ruler is not updated when I move the cursor on the photo. The bug can be reproduced, e.g., on "denoise profiled" module.

Many thanks!

History

#1 Updated by Pascal Obry over 4 years ago

  • % Done changed from 0 to 10
  • Status changed from New to Confirmed

#2 Updated by Roman Lebedev over 4 years ago

Might be related to #10726
Is module enabled when you experience the issue?

#3 Updated by Serge Gavrilov over 4 years ago

Yes, the module is enabled. I try to construct the paramtric mask, but cannot do this, because the rulers do not move.

#4 Updated by Ulrich Pegelow over 4 years ago

I need to come back to the TO. What do you mean by "the rulers don't change"?. The four triangle rulers that allow you to construct a parametric mask are not supposed to change. The color picker is a feature that helps you to orient yourself in the ruler. It will show a small white vertical bar that indicates the respective value at the mouse cursor position. Or, when the color picker is in area mode, it will display the range of values within that are plus the average value.

#5 Updated by Serge Gavrilov over 4 years ago

Ulrich Pegelow wrote:

I need to come back to the TO. What do you mean by "the rulers don't change"?. The four triangle rulers that allow you to construct a parametric mask are not supposed to change. The color picker is a feature that helps you to orient yourself in the ruler. It will show a small white vertical bar that indicates the respective value at the mouse cursor position. Or, when the color picker is in area mode, it will display the range of values within that are plus the average value.

Of course, I understand this!

But now I discover that my description was incomplete. The problem is only with "denoise (profiled)" module. But after an attempt to use pick color tool in parametric blending interface for this module, pick color tool for other modules become also broken with current image.

So, to reproduce, try to use pick color tool with "denoise (profiled)" parametric blending. Still broken in 2.0.1.

#6 Updated by Serge Gavrilov over 4 years ago

Can anyone reproduce this? Again, the problem is only with "denoise profiled" module, perhaps all others modules works well.

#7 Updated by Serge Gavrilov over 4 years ago

The same problem with equalizer. Ping!

#8 Updated by Serge Gavrilov over 2 years ago

I cannot reproduce anymore this bug with 2.2.5.

Also available in: Atom PDF

Go to top