Project

General

Profile

Bug #10888

Crop tool often fails on new iMac

Added by Hiram Baasch over 4 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
01/24/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0.0
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I didn't notice this running 2.0 on my old 2011 iMac, but on my new 27-inch one (late 2015, 3,3 GHz Intel Core i5, 24 GB 1867 MHz DDR3, AMD Radeon R9 M395 2048 MB, 2TB Fusion Drive) more often than not the crop tool fails, because I cannot drag the image borders. Sometimes after trying many times they will move, but there's surely something wrong with this tool, on this hardware.


Related issues

Is duplicate of darktable - Bug #10838: crop and rotate: difficult to move to the edgeTriaged12/31/2015

History

#1 Updated by Roman Lebedev over 4 years ago

  • Is duplicate of Bug #10838: crop and rotate: difficult to move to the edge added

#2 Updated by Roman Lebedev over 4 years ago

  • Status changed from New to Duplicate

#3 Updated by Roman Lebedev over 3 years ago

  • Target version changed from Candidate for next patch release to 2.2.0

#4 Updated by Jilles van Gurp over 1 year ago

This is still broken for me in 2.4.4; also see #10838.

#5 Updated by Jilles van Gurp over 1 year ago

After updating to Mac OS Mojave, the problem seems solved. I also noticed opencl now works a lot better, which I'm guessing was related. The past few versions actually failed to initilize that. The same installation that was previously having this issue now seems to work after the mojave update. So, if you are running Darktable on mac, you probably want to upgrade.

Also available in: Atom PDF

Go to top