Project

General

Profile

Bug #10884

No OpenCL for newest iMac with AMD Radeon R9 M395

Added by Hiram Baasch over 3 years ago. Updated over 3 years ago.

Status:
Incomplete
Priority:
Low
Assignee:
-
Category:
General
Start date:
01/18/2016
Due date:
% Done:

20%

Estimated time:
Affected Version:
2.0.0
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Testing darktable 2.0 on a friend's iMac 27-inch (late 2015) with a AMD Radeon R9 M395 graphic card, the OpenCL check box in Core Options was still greyed out and un-clickable. Was I mistaken to expect this graphics card to be supported? Or is it an oversight that can be corrected?

History

#1 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Please show output of darktable-cltest

#2 Updated by Hiram Baasch over 3 years ago

Would love to, but I don't have the hardware here. I will in a few days, probably. I'm no coder, so please tell me what to enter, and where, exactly.

#3 Updated by Igor Kuzmin over 3 years ago

cltest isn't included in package. so just start DT like that and post the output:

/Applications/darktable.app/Contents/MacOS/darktable -d opencl

#4 Updated by Hiram Baasch over 3 years ago

I can test this now on my own iMac 27 inch, late 2015, with 3,3 GHz Intel Core i5, 24 GB 1867 MHz DDR3, AMD Radeon R9 M395 2048 MB. Most of the time the OpenCL checkbox is available, but sometimes, when as far as I can tell no parameters have changed, it is not. I must say that even when OpenCL is (supposedly) activated, darktable is considerably slower on this new beast of a machine (fast processor, lots or RAM) than on my previous, much less muscular iMac (2011). But I will add a different issue about that.

Also available in: Atom PDF

Go to top