Project

General

Profile

Bug #10864

Crash when exporting photos - exiv2

Added by Anonymous almost 2 years ago. Updated about 2 months ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
01/10/2016
Due date:
% Done:

0%

Affected Version:
2.0.0
System:
openSUSE
bitness:
64-bit
hardware architecture:
amd64/x86

Description

darktable 2.0.0-119.2, 64bit, suse leap 42.1, crashes when exporting
more than three JPGs to JPG, setting 90%, at a time.

darktable_bt_WUQ8AY.txt Magnifier (15.3 KB) Anonymous, 01/10/2016 02:33 PM

20151218_1321080_AIDAstella_orgM.jpg.xmp (1.92 KB) Anonymous, 01/10/2016 03:11 PM

20151218_1321080_AIDAstella_orgM.jpg (4.88 MB) Anonymous, 01/10/2016 03:13 PM

20151218_1352420_AIDAstella_orgM.jpg.xmp (2.43 KB) Anonymous, 01/10/2016 03:13 PM

20151218_1352420_AIDAstella_orgM.jpg (8.28 MB) Anonymous, 01/10/2016 03:14 PM

20151218_1353180_AIDAstella_orgM.jpg.xmp (2.43 KB) Anonymous, 01/10/2016 03:14 PM

20151218_1353180_AIDAstella_orgM.jpg (5.33 MB) Anonymous, 01/10/2016 03:14 PM

20151218_1409560_AIDAstella_orgM.jpg.xmp (1.92 KB) Anonymous, 01/10/2016 03:14 PM

darktable_bt_SB51AY.txt Magnifier (20.6 KB) Anonymous, 01/10/2016 03:14 PM

20151218_1409560_AIDAstella_orgM.jpg (5.92 MB) Anonymous, 01/10/2016 03:15 PM

conf_used_with_suse_13.2_darktable_bt_46EABY.txt Magnifier (17.2 KB) Anonymous, 01/10/2016 09:35 PM

exiv2_0.23-5.4.1_darktable_bt_II50AY.txt Magnifier (15.2 KB) Anonymous, 01/10/2016 09:35 PM

exiv2_0.25-4.8_darktable_bt_ZUI5AY.txt Magnifier (14.3 KB) Anonymous, 01/10/2016 09:35 PM

no_exiv2_darktable_bt_FLMEBY.txt Magnifier (14.3 KB) Anonymous, 01/10/2016 09:35 PM

darktable_crash.txt Magnifier - MacOS stack trace (4.5 KB) alex furmansky, 01/13/2016 12:02 AM

CIMG4704.JPG (8.96 MB) Anonymous, 01/28/2016 11:13 PM

History

#1 Updated by Roman Lebedev almost 2 years ago

  • Status changed from New to Incomplete
  • % Done changed from 0 to 20

Looks like exiv2 issue.
Also, please attach some of those jpg's that cause the crash.

#2 Updated by Anonymous almost 2 years ago

I repeated the export experiment, added are four JPGs plus their xmp files plus the bug-report for these four JPGs

#3 Updated by Pedro Côrte-Real almost 2 years ago

What exactly do you do to reproduce this? I've imported these 4 images and exported them to JPGs at 90% quality with no issue.

#4 Updated by Pedro Côrte-Real almost 2 years ago

You seem to be on exiv2 0.25 while I'm on 0.23 so it may be a bug in the newer version.

#5 Updated by Anonymous almost 2 years ago

Pedro Côrte-Real wrote:

You seem to be on exiv2 0.25 while I'm on 0.23 so it may be a bug in the newer version.

You are right. The problem seems to be caused by the exivtool 10.00-2.1 package in the OBS-multimedia-photo Repository for suse leap 42.1. I reset it to the exivtool 10.00-6.2 from the original leap 42.1 package. The problem went away.

Thanks
Peter

#6 Updated by Pedro Côrte-Real almost 2 years ago

Peter Mc Donough wrote:

Pedro Côrte-Real wrote:

You seem to be on exiv2 0.25 while I'm on 0.23 so it may be a bug in the newer version.

You are right. The problem seems to be caused by the exivtool 10.00-2.1 package in the OBS-multimedia-photo Repository for suse leap 42.1. I reset it to the exivtool 10.00-6.2 from the original leap 42.1 package. The problem went away.

That's definitely not it. We don't use exiftool at all, only exiv2.

#7 Updated by Anonymous almost 2 years ago

I have to correct myself. The problem is still there.

After learning that a bug in exiv2_0.25 may be the reponsible part I did some tests.

exiv2 is not required for darktable on my leap 42.1. At least, Yast doesn't install it automatically and darktable seems to run fine, unless I want to export JPGs.

Tests with suse leap 42.1 64bit, 16GB RAM, AMD-4-core prozessor
The hardware was sufficient with suse 13.2 and darktable 1.6.8.

I renamed my darktable home configuration and tried each time with a fresh home configuration (no changes apart from changing cache space from 256 MB to 1500MB.) Export settings left at 95%

Same result from: exiv2_0.23, exiv2_0.25, no exiv2 at all.
I can't even export a single JPG anymore.

Returning to my old home-configuration, the one I brought from suse 13.2 to Leap 42.1. Same problem at 90% export size.

Why? Probably the full moon?
I'll try to get someone from the suse-list checking out exporting JPGs on leap 42.

Attached are the bug-files from the tests

cu
Peter

#8 Updated by Pedro Côrte-Real almost 2 years ago

Peter Mc Donough wrote:

exiv2 is not required for darktable on my leap 42.1. At least, Yast doesn't install it automatically and darktable seems to run fine, unless I want to export JPGs.

That's probably the package that has /usr/bin/exiv2. Darktable links against the exiv2 library that is provided by a different package that the exiv2 package also depends. On Ubuntu that's called libexiv2-14 for the 0.25 version and libexiv2-12 for the 0.23 version.

Installing 0.23 won't help either as they are not binary compatible so the 0.23 package will install /usr/lib/libexiv2.so.12 and the 0.25 package will install /usr/lib/libexiv2.so.14. Since your darktable is compiled against 0.25 it will always use the .so.14 file and never the .so.12.

#9 Updated by Roman Lebedev almost 2 years ago

  • Subject changed from Crash when exporting photos to Crash when exporting photos - exiv2

#10 Updated by Anonymous almost 2 years ago

Darktable 2.x new features look very attractive
Using Darktable 1.6.8 in Leap 42.1 won't help as it also uses the "wrong" lib.

So what are my options?
Returning to opensuse 13.2 and adding darktable 2.x from a repo there?

cu
Peter

#11 Updated by alex furmansky almost 2 years ago

Hi,

I have same problem with MacOS. Should I create a new bug, or join this one?

#12 Updated by Pascal Obry almost 2 years ago

If it's really the same issue, please post here, it may help tracking this one down.

#13 Updated by alex furmansky almost 2 years ago

Pascal Obry wrote:

If it's really the same issue, please post here, it may help tracking this one down.

It looks very similar, however unix version crashes in Exiv2::Internal::TiffComponent::addPath(...), and MacOS is in Exiv2::Internal::TiffMnEntry::doAddPath(...), one step before. I also found http://dev.exiv2.org/issues/1146, which may be relevant, however, no solution there.

#14 Updated by alex furmansky almost 2 years ago

alex furmansky wrote:

It looks very similar, however unix version crashes in Exiv2::Internal::TiffComponent::addPath(...), and MacOS is in Exiv2::Internal::TiffMnEntry::doAddPath(...), one step before. I also found http://dev.exiv2.org/issues/1146, which may be relevant, however, no solution there.

As a matter of fact, it looks even more interesting, since both mine and Peter's problem images are taken with CASIO cameras. It may be relevant as the problem is located in code dealing with metadata information. Exiv2 seems to use some different logic depending on camera vendor to read metadata from images, probably the issue is specific for CASIO cameras.

#15 Updated by Anonymous almost 2 years ago

Alex, you are right.

renaming darktable files in home
Clean installation of
darktable 2.0.0-119.2, 64bit, suse leap 42.1,
no configuration changes

I took four panasonic RAWs (.rw2) and exported them to JPG. No problem!
A single casio JPG of my examples crashed darktable.

So, the problem may be indeed connected to casio.

cu
Peter

#16 Updated by Anonymous almost 2 years ago

Peter Mc Donough wrote:

It has been a few days since I reported the problem with
darktable 2.0.0-119.2, 64bit, suse leap 42.1
and exporting a casio photo, a new "pure" example is attached to this report.
Exporting it with darktable crashed it again.
Is there any hope for a solution with the next update of darktable?

cu
Peter

#17 Updated by Tobias Ellinghaus almost 2 years ago

  • Status changed from Incomplete to Triaged

I can confirm, seems to be an exception in libexiv2 (it either thinks it's a TIFF or is using weird function names).

#18 Updated by Anonymous over 1 year ago

Hi,

Darktable 2.0.3-130.1 is still crashing when exporting "my" casio JPGs.
Tested today in a virtualbox guest suse leap 42.1 and a short time ago with an guest opensuse 13.2. 32bit.

As stated bevor, the same casio JPGs don't crash darktable 1.6.9 in my present opensuse 13.2 64bit.

Any hope?

cu
Peter

#19 Updated by Roman Lebedev over 1 year ago

The only solution i see is to upgrade exiv2 library. (and recompile dt against that new exiv2 lib)
This is purely exiv2 bug, and it is a crash and not an exception so we can not even catch it.
If the newer exiv2 (their current dev version) still crashes - i'd say bother exiv2 devs in their redmine...

#20 Updated by Alan Pater over 1 year ago

Roman Lebedev wrote:

The only solution i see is to upgrade exiv2 library. (and recompile dt against that new exiv2 lib)
This is purely exiv2 bug, and it is a crash and not an exception so we can not even catch it.
If the newer exiv2 (their current dev version) still crashes - i'd say bother exiv2 devs in their redmine...

Thanks Roman. This was fixed in exiv2 8 months ago.

http://dev.exiv2.org/issues/1106

Peter, you either need to compile the current exiv2 code on your system or wait for exiv2 v0.26 to be available for your distribution.

#21 Updated by Anonymous over 1 year ago

Thank you!

I passed that info to:
https://bugzilla.suse.com/show_bug.cgi?id=964344

It might help.

cu
Peter

#22 Updated by Roman Lebedev 2 months ago

  • Status changed from Triaged to Closed: upstream
  • % Done changed from 20 to 0

#23 Updated by Roman Lebedev about 2 months ago

  • Target version set to 2.4.0

Also available in: Atom PDF