Project

General

Profile

Bug #10804

Duplicates will not deleted

Added by Christoph Dunschen almost 4 years ago. Updated almost 4 years ago.

Status:
Triaged
Priority:
Low
Assignee:
-
Category:
Lighttable
Start date:
12/22/2015
Due date:
% Done:

20%

Estimated time:
Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi,

when I try to delete the duplicates of a picture, XMP files will not deleted from hard disk.
At next directory import the deleted duplicates are back.
I test it with the new "Recycle.bin" and the direct delete function. Both times XMP files will not deleted.

I use 64Bit Version on ArchLinux. Please test it on your system too...


Related issues

Related to darktable - Bug #10734: delete/erase removes file from library but not file systemClosed: invalid11/22/2015

History

#1 Updated by Roman Lebedev almost 4 years ago

Is trash feature enabled?
Are you sure you are clicking on "delete" (from library AND filesystem), not "remove" (from library) ?

#2 Updated by Roman Lebedev almost 4 years ago

  • System changed from unknown to all
  • Affected Version changed from 2.0rc4 to git development version
  • % Done changed from 0 to 20
  • Status changed from New to Triaged

#3 Updated by Christoph Dunschen almost 4 years ago

Hi Roman,

yes I'am shure that i click on "delete" and not "remove".

Currently I renamed ".conig/darktable" to start with a complete new Darktable configuration.
But it is the same, no XMP will be ever deleted.
I test it with/without thrash and with/without asking before deleting.

(PS. Interesting detail: when reimporting directory, the non-deleted XMP files redirect to complete other directory, see attached picture. There are no mushroom pictures in the selected directory...)

#4 Updated by Roman Lebedev almost 4 years ago

Yes, i was able to reproduce it locally.
Not sure what is going on though, i seriously doubt the bug is in our code and not in glib/gio.

#5 Updated by Roman Lebedev almost 4 years ago

  • Related to Bug #10734: delete/erase removes file from library but not file system added

Also available in: Atom PDF

Go to top